PCSX-Rearmed/Cores not working properly (GPD Win 2 - Win10-64Bit)


#1

I Load a Core, then Load a Game. PSX keeps crapping out with Hydro Thunder. First indicator is you get to the Start of the Race and the Right half of the Screen is Green. Then on the 1st Turn, the Graphics get Stuck and you cant do anything. Odd thing is, it seems like the ACTUAL ePSXe Emulator also does not want to work, either.

-----Best to use Beetle PSX HW. You will get a Warning about Disc Speed Slowdown, but it seems to be running perfectly.

Also, if I Update the Dreamcast Cores, they BOTH wont Load anything. Good thing I got a older Copy of the Cores.


#2

On x86/64 devices, PCSX-ReARMed (unrelated to ePSXe, for the record) doesn’t get all of the awesome ARM-specific goodies that make it worthwhile. If you can get full speed with Beetle-PSX, you should definitely use it instead. You can probably fix the disc speed slowdown warning by using the ‘cache’ setting for disc access (I forget the exact name of the core option).


#3

Yeah, I realized my Error after the Post, sorry. It is weird though, because on my GPD Win 1, it worked perfectly. Also, I could not run either of the Dreamcast Cores. I had to Delete RA and start fresh with a older Build of the Cores, and at least Reicast works. Have not tried Redream yet.

EDIT: It is a Core Issue. Just tested PCSX on my PC. Same exact thing. Screen tearing then at the first Turn it Tears more and Locks up.