PCSX2 core are working in Linux?

Hello. PCSX2 core in Retroarch current version 1.9.5 work in Linux ? Firmwares files are correct checksum and pass core test when entering core options. In same system PCSX2 standalone version 1.7.0.2 works.

Is exactly need an GPU with 2 GB VRAM ?

Thanks for your reply.

The main issue in linux right now is that it’s linked against a specific version of libpng (it should show it missing in the logs). You can probably just symlink the version you have installed to the one it’s looking for. I’m not sure if that’ll get it working, but it’ll get it past that problem.

EDIT: I just tried it myself and it also wants libaio1 installed. Once I got that on there, it tried to load but crashed on something around memory cards.

Thanks for your reply. In logs (even selected others logs types) not is listed any issue about PCSX2. Only is displayed error loading core or retroarch crash closing. PCSX2 core need dependencies that standlone version not use ?

In others words PCSX2 core in moment not is working ?

They’re dependencies from standalone. We usually try to statically link all dependencies at compile time for libretro cores, but that isn’t happening with pcsx2.

I not understand if is because security in OS creating that issue. If possible create a PCSX2 version compiled to be no gui with command line ? If yes is possible create a core being a appimage file ? is possible add all dependencies in a appimage file and not will be blocked by system. Please is possible list here or in https://docs.libretro.com/guides/navigating for me and for others user all dependencies files naming with correct version ? Thus is more simples to help to debug. Thanks for your reply and have a nice week.

I can confirm that pcsx2 isn’t working in linux … Standalone PCSX2 works - so it must be something with the core…

Gran Turismo 3 works for me slow in RetroArch even on Native Resolution (problem with sound). Works normal in PCSX2.

@Kr87 You use what OS ?

Windows 11. I used Windows 10 before.

You may check this issue.

You should try to make a test by compiling the core by yourself with

git clone https://github.com/libretro/pcsx2.git
cd pcsx2
mkdir build
cd build
cmake .. -DLIBRETRO=ON -DCMAKE_BUILD_TYPE=Release -DENABLE_QT=OFF
make -j$(nproc)

The core pcsx2_libretro.so will available in pcsx2/ inside the build/.

You will need some libs among others : libaio, libpcap,libpng, liblzma, libxml2, zlib1g.

The libs above are for use when compiling or when starting the core ?

You will need to compile and libaio will be required for using the core.

linux-vdso.so.1 (0x00007ffdc05d8000)
libz.so.1 => /usr/lib/libz.so.1 (0x00007f44fed1c000)
libaio.so.1 => /usr/lib/libaio.so.1 (0x00007f44fed17000)
libOpenGL.so.0 => /usr/lib/libOpenGL.so.0 (0x00007f44feceb000)
libGLX.so.0 => /usr/lib/libGLX.so.0 (0x00007f44fecb8000)
libGLU.so.1 => /usr/lib/libGLU.so.1 (0x00007f44fec62000)
librt.so.1 => /usr/lib/librt.so.1 (0x00007f44fec57000)
libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x00007f44fea3f000)
libm.so.6 => /usr/lib/libm.so.6 (0x00007f44fe8fb000)
libgcc_s.so.1 => /usr/lib/libgcc_s.so.1 (0x00007f44fe8e0000)
libpthread.so.0 => /usr/lib/libpthread.so.0 (0x00007f44fe8bf000)
libc.so.6 => /usr/lib/libc.so.6 (0x00007f44fe6f3000)
/usr/lib64/ld-linux-x86-64.so.2 (0x00007f450b2cc000)
libGLdispatch.so.0 => /usr/lib/libGLdispatch.so.0 (0x00007f44fe63b000)
libdl.so.2 => /usr/lib/libdl.so.2 (0x00007f44fe632000)
libX11.so.6 => /usr/lib/libX11.so.6 (0x00007f44fe4f1000)
libxcb.so.1 => /usr/lib/libxcb.so.1 (0x00007f44fe4c7000)
libXau.so.6 => /usr/lib/libXau.so.6 (0x00007f44fe4c2000)
libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0x00007f44fe4ba000)