Physical Disc Support in which versions?

Hey everybody, I’m excited to join the forums over here.

I have been installing Retroarch on a number of systems recently. While doing so I learned about the “retroarch disc project” which was implemented in 2019, but I was surprised to find the feature available in some versions but not others.

When I read about the feature here https://www.libretro.com/index.php/category/retroarch-disc-project/ it says that it should be available in Linux and Windows versions of Retroarch.

I found the feature to be available to be available in Windows with an added Retroarch installation as well as on a Lakka USB version running on the same machine (I guess this what the Linux part above refers to).

I understand that the feature is not implemented in Lakka running on a Pi board, but what surprised me is that I also can’t see the feature in a fresh Ubuntu setup running the latest (August 2020) Retroarch build.

As much as I appreciate Lakka for what it is, I find the Retroarch versions runnings in Windows or on (a full) Linux much easier to navigate (plus I obviously prefer Ubunto to Windows), which ultimately leads to my question:

Why don’t I get the the disc features (load disc & dump disc) from Retroarch running on Ubuntu ? The statement from the Retroarch page “available in Linux and Windows” made it sound as it should be available - just like on Windows.

Any hints would be appreciated!

Thanks! Didi

hmm, probably just a matter of missing a dependency and/or a configure flag. I’ll try to track it down.

Are you using a build from the PPA or one of the “universal” packages, like snap/flatpak? If the latter, they often have limitations in things they can access on the host system.

Thanks for the quick reply!

I’m using the SNAP version since the “get retroarch” button onthe RA website basically takes you there. It’s the version from August 8th.

You can see it running here. Disc is loaded as well (see icon on the left). The setup (with this particular drive is tested and works tremendously well in Lakka).

If you think, installing the PPA version instead might help, I can try that.

And to follow up on the original question: RA Windows, RA Linux and Lakka are the version that should have disc support, right ? What about any of the Pi versions ? Could the flatpak or snap linux build be installed on a Pi 4 with Raspberry OS or are the versions on flatpak and snap for x86 CPUs only ?

Thanks again! Didi

It looks like there are armhf and arm64 build for the snap, so it should work on RPis, but it depends on what the sandbox allows. There are some things, like discord rich presence, that are just not compatible with the sandboxing and there’s no choice but to disable it.

However, if you’re running a full OS (i.e., not a minimal distro like lakka), you can always build it to suit your needs.

I continued trying quite a bit of different OS and retroarch versions to find where physical disc support is available and where it isn’t.

I first tried installing the PPA version on x64 Ubuntu 20.04, but this doesn’t seem to be available right now. I can load the repository, but I can’t actually get Retroarch from it. Just gives a lot of errors (something about dependencies). Flatpak and Snap doesn’t have the CD support enabled.

As mentioned before Lakka x86 has the CD option available and works nicely. Power supply is an issue though with external USB2 drives. USB3 drives work a lot better and so do older bulkier drives with external power supplies. On drives without sufficient power (or some drives in general) RA can’t properly play red book audio. It’s very stuttery and breaks the gameplay as well.

On the Rasperry Pi side I tried arm64 Ubuntu, both with it’s classic Desktop and with Mate. Mate performs MUCH better than the original desktop. Installing the PPA version here works, I just had to compile a few cores on my own. And - surprise - even disc support is enabled.

My question to the community (or sombody deeper into the project): with disc support being available on x86 Lakka (plus CD supported being integrated in PPA retroarch for arm64 Ubuntu), are there any other Lakka versions that have it enabled? This is currently running on the cheapest NUC available (June Canyon, under $100), but I’d like to try a version with disc support enabled that’s running on something even smaller, like a small arm box or a SBC.

Thanks, Didi

I had a lot of fun trying Retroarch’s disc playback features on variouso Pi and x86 platforms over the past few weeks. Extremely enjoyable and pretty stable.

Does anybody know if the “load disc” feature is enabled on the Retroarch Android version available on the google play store? If so, I might get one of the new chromecast dongles to give this a try.

1 Like

AFAIK, it’s not. I’ve seen others ask about it, too.

Another question on the same topic. I’ll just ask in the existing thread instead of starting a new one.

Has there any work been done within Retroarch on how save files and save states are handled for physical discs?

I found that RA uses the same file name for all discs, so save states per se work OK, but once you change the disc, save states for the previous game are overwritten or if you try loading a save state (from the previous game), you end up with garbage in memory. For SRAM files you basically end with a single file across all discs (just like on original hardware), because RA assumes the same “rom” name for all discs inserted.

When dumping discs, individual names are created for each disc, so it would make sense for RA just to use a similar naming convention for save states and files for physical discs in general.

(these observations are based on a slightly dated version on retroarch (but one that’s running great on all Pi devices) - hence my question about any recent changes to this behaviour).

As usual, thanks for any advice! Didi