Players 9 and 10 Do Not Work on RetroArch

When you use retroarch, players 9 and 10 do not work. 8 controllers seems to be the maximum number that retroarch will accept at one time. I do not think this issue has been well documented because Saturn Bomberman is the only game on retroarch that I am aware of that supports up to ten controllers simultaneously. One redditor says the issue also applies to players 11-16 as well, but I do not have any 16 player games to test that theory out on:

Before anyone asks, I have gone to Core Options > Input > and set 6Player Adaptor on Port 1 and 6Player Adaptor on Port 2 to ON. I have also gone to Settings > Input > Maximum Users and tried 10, 12, and 16 players, but nothing worked.

I am currently trying to get this working on the steam deck. supports 10+ controllers at the same time (I have tested ten simultaneous controller on 10 player PICO Park: Classic Edition, and it works great).

It does not appear that anyone has been able to get 10 players simultaneous play working on RetroArch:

I believe the xinput api only supports up to 8 controllers if that’s what you are using (and i believe steam “convert” controllers into xbox controllers, meaning you are most likely using xinput).

I don’t believe that’s correct. As I mentioned in my original post, I am able to get 10 controllers working in other Steam games (ie Pico Park Classic). Also, I can get 10+ controllers are able to navigate the steam menus simultaneously. It’s just RetroArch that won’t accept more than 8 controllers.

Ok, so you are saying you checked “Settings > Drivers > Controller” (or was it “Settings > Drivers > Input” ?) and already confirmed it’s not set to xinput ?

1 Like

@FixSaturnBomberman in case i wasn’t clear in my previous posts, it is factual that xinput doesn’t support 9/10 players (meaning that other game you are talking about is probably using dinput) and that you won’t be able to use 9/10 controllers if xinput is set in retroarch’s settings (which imho is the default setting for the retroarch steam builds, since steam has a feature to “standardize” controllers into xbox/xinput controllers)

1 Like

HOLY COW!! I believe that fixed it! Changing Settings > Drivers > Input to pretty much any other setting other than x did the trick. THANKS SO MUCH!

Follow up question: since changing the Settings > Drivers > Input to wayland, sdl2, udev, or linuxraw all seem to work on my initial test, which one of the four would your recommend? Settings > Drivers > Controller is set to sdl2 by default on my end, so I’m guessing it would be best if the input was also set to sdl2, but I really don’t know much about this topic.

I didn’t expect you were running steamos/linux since you mentioned a game that is listed as windows-only on the steam store, neither did i know the x driver on linux had similar limitations to the xinput driver on windows.

Udev has direct access to the input devices instead of going through some api (and its limitations), that would be my recommendation. I don’t know if there are edge cases where you’d want to use something else.

Thank you again so much!