Playstation cores unable to load BIOS

System info:

-Intel Core i7 9700k -16 gigs RAM -nVidia GeForce 2070 -Windows 10 Home (x64) Version 1809 (build 17763.253) -Retroarch 1.7.5 -Beetle PSX HW c20eac9 -PCSX-ReARMed r22 c8e850f

I am now day two into troubleshooting both Beetle PSX HW and PCSX-ReARMed’s inability to load my playstation bios files. Beetle PSX HW refuses to boot games and errors out with “Unable to load game.” Log file shows:

[libretro INFO] Loading D:\Retroarch\ROMs\Sony - Playstation\Wipeout XL (USA)\Wipeout XL (USA).cue...
[libretro INFO] Checking if required firmware is present.
[libretro ERROR] Firmware is missing: scph5501.bin
[libretro ERROR] Content cannot be loaded
[ERROR] Failed to load content.

PCSX-ReARMed will launch the games but give an error about not finding BIOS files and compatibility will suffer because of it.

I have verified the following information and taken the following troubleshooting steps:

BIOS files are placed in the system folder and are correctly named:

MD5 values have been verified with the values posted on the Documents section

Verified Retroarch has the bios directories set to the correct folder:

Verified Beetle PSX HW sees the files via the information button:

Launched game, error is logged:

I have attempted:

-Removing all files from system folder. Same error.

-Only putting the verified playstation bios files in folder. Same error.

-Deleting cores and redownloading. Same error.

-relocating bios files, pointing Retroarch’s directory at new folder location. Same error.

At this point I’ve done everything every document has said to verify my files are correct. I’m completely lost as to what could be happening. I know the games run fine without the bios files in PCSX-ReARMed, but I would like to try Beetle PSX HW and make sure my library has full compatibility. Are there any further troubleshooting steps to take here?

1 Like

Can you post a complete verbose log, please? My first guess is that you have a core config override that’s pushing the system dir setting somewhere else, but without I can’t say either way without the log.

1 Like

Here is a pastebin with a verbose log:

1 Like

Well, not an override:

[INFO] [overrides] no core-specific overrides found at D:\Retroarch\config\Beetle PSX HW\Beetle PSX HW.cfg.

However, this appears to be the issue:

[INFO] Environ SYSTEM_DIRECTORY: "D:\Retroarch\ROMs\Sony - Playstation\Ace Combat 3 - Electrosphere (USA)\".

The question now is: what is wrong with your system directory? Could it be a permissions issue? Is D: your system drive or something external?


D: is my internal spinning disk drive. Retroarch is at the root of said drive. My D: is not my system drive (That’s currently a 512 gig NVMe as c:).

I thought it could be something like a read only setting, but the files were clean.

Can you try downloading a recent date-stamped nightly build from, backup and replace your retroarch.exe with the one you dnownloaded and see if that makes any difference?


Moved the stable exe’s to a backup folder, placed the exe’s from 1/21 nightly build. Same results (though I do not get a pop up error at all).

Log here

EDIT: For the sake of thoroughness, here is another log with the nightly build using a different game from a different region.

To me, it looks like it’s trying to find the BIOS in whichever folder you are loading the roms from. For instance, it shows Askua/Asuka.cue (you get the jist) and then looks for BIOS in asuka/

Out of curiosity, if you copy your BIOS to the same folder as the game, does it load?

If this is the case, it might be worth opening retroarch.cfg and using CTRL+F to see if there’s a line in there that’s trying to force your system dir to the content directory.


Great idea. I reverted back to the stable release exe’s, copied scph5500.bin into the game’s folder, and was able to successfully launch the game and play. Log here:

Opening my config file, I find the following lines:

system_directory = ":\system"
systemfiles_in_content_dir = "true"

I have changed true to false, saved the file, and removed the bios file from the game’s directory. The game launches. The log file indicates that it found the file in the systems directory

[libretro INFO] Loading D:\Retroarch\ROMs\Sony - Playstation\Asuka 120% Excellent - Burning Fest. 
Excellent (Japan)\Asuka 120% Excellent - Burning Fest. Excellent (Japan).cue...
[libretro INFO] Checking if required firmware is present.
[libretro INFO] Firmware found: D:\Retroarch\system\scph5500.bin
[libretro INFO] Firmware SHA1: B05DEF971D8EC59F346F2D9AC21FB742E3EB6917

Full log file here:

Thank you, I believe this has solved my issue. Do you know if this flag is editable from the retroarch gui? I must have accidentally flipped a switch somewhere.


Alright! I’m glad you got it working! I feel like I’ve seen that setting before somewhere, but I might also be thinking of saves/savestates.


systemfiles_in_content_dir = “true”

this is suppose to be normally “OFF”, together with other related something_in_content_dir stuff…(they should at least be normally off, unless the default is not writable/does not exist…)


I had the same issue. I went and reset it to look for bios in the RetroArch folder (even though it already was set to that folder) and it fixed the problem.

1 Like

I have the same issue. BIOS file is correct, checksums are verified, Retroarch core information correctly says the BIOS files are “Present” (with correct checksums etc, which I’ve verified separately using shell). But still, trying to load any PS1 game gives

Error Firmware is missing scph5501.bin

Yet that file is correct, is present, is showing as correct and present in the RetroArch info. (And that BIOS file works for other emulators.)

Something is wrong. I’ve used it for years too, it’s only recently that it suddenly became a problem.

When I manually try to change the System / BIOS directory setting to something else, it doesn’t seem to be able to find the /Users/username/Documents/Retroarch folder. So, the problem seems like a permissions issue, but, Retroarch is authorized for file access in Privacy/Security, and I even tried manually setting “Read Only” for “Everyone” permission for that folder.