Poor performance on Beetle PSX i5-4590 + GTX 1650 [solved]

When running Beetlepsx on my PC I’m getting shockingly low performance at anything above 1x resolution. 4X is a slideshow and 2x has distorted audio and frequent hiccups.

The game I’m using in my test is Threads of Fate. I’ve tweaked a lot of settings and the only thing that seems to tank performance is upping the resolution. I get significantly better results if I go into the retroarch menu before launching the game or loading the core and set the video backend to Vulkan.

beetle psx is software afaik and gets too demanding above 1x resolution. Its accurate though.

yeah, sounds like it’s not actually using the GL renderer and falling back to software instead. Can you post a log? that will tell us for sure.

Attached https://pastebin.com/QFdUzyAv

I used a different game and got the same results even in Vulkan. Also crashing

Looks like you’re using the non-HW core, which only has the software renderer, and for that log, at least, you were using the vulkan driver.

Hmm so do I have any options here? I’ve switched to the other PCSX-rearmed core so I can at least avoid the crashing but it has no resolution options.

Do you not see the beetle-psx-hw core in the list? That’s the one you need.

Ahh gotcha thnks realized what that means now.

1 Like

Yeah make sure you are using the HW core. I played through Atl3 and Ehrgiez with 8x resolution on an i7 950 with no issues. A newer i5 than that should work more than fine with the HW core.

On my i7 2860qm with a gt540m I cannot get past 2x. At 2x everything is fine. At 4x it’s totally unplayable.

That usually means you’re not actually using hardware rendering, but software. What video driver are you using?

This is weird. Really. Read further please. Sorry for bumping this thread up but I still cannot open a more detailed topic.

I have set Retroarch on GL video driver and Beetle PSX HW to renderer “hardware”. At 2x everything is fine. At 4x I can perfectly play but I get slow music in the menus. EG: gran turismo is totally fine in game, it also has the right timing for the music, but in the main menu the music is slow. Crash Bandicoot at 4x has slow music everywhere but it’s totally playable.

You know what else? If I set Retroarch to D3D11 video driver, when I load a content in Beetle PSX HW it tells me this: “Unable to find or open hardware renderer for frontend preferred hardware context. Falling back to software renderer”. And I automatically end up with 1x resolution and crappy performance.

That damn Nvidia Optimus is correctly set to run Retroarch with the “discreet gpu” on high performance mode.

Why should I switch from GL to D3D11 you migh be asking. Because with the GL video driver selected I have stutters in other way less demanding emulators like NeoGeo, FBA, Super Nes.

I have opened a proper topic now. You can find it in the Windows 10 related subforum :slight_smile: