Port 0 problem

Hi all, First time poster so bear with me please. Have been using RetroArch on my Shield TV with little problem until tonight when all of a sudden I can no longer get RetroArch to recognise any controller as Port 0. Whatever I open RA up with, be it Shield remote, M30 or Xbox One pad it always starts configured as Port 1 and therefore doesn’t allow me to navigate. I was trying to sort out the keys for my M30 pad when this began so wonder if I’ve messed something up. I have unplugged and plugged back the Shied back in, removed all Bluetooth controllers and reset the RAconfig (which changed the look back to default etc) but the problem persists. Any ideas please as I’m tearing my hair out. Using 1.88 RA on Shield TV. Thanks in advance for any help.

Awhile back we changed the numbering from 0 to 1 just because it was confusing for people, so that may not be the cause of your issue.

Are you launching RetroArch using the controller you intend to use? Or are you using a Shield remote, etc?


It’s an odd one then, and probably relating to setting I’ve missed up. If I open RA with the Shield remote it simply won’t respond, same if open it with an Xbox One pad connected wirelessly using an 8bit do dongle (which RA detects as an x360 pad). However it WILL recognise and work ok if I comment the pad wired (recognising it as a Logitech F controller).

I’m not sure what’s happened as before I could navigate the menus fine with all three of the above.

I suspect it was something I did when trying to get the M30 configured, which I’ve given up on now.

Any ideas please?

I guess basically it seems it’s auto detecting the controllers (shield remote, Xbox one connected to 8bit do) saying they’re configured but not allowing me use them automatically as it used to do. I’m guessing it’s a setting in Binds but I can’t seem to figure it out. Been at it hours now, with no success. Doesn’t help that sometimes when I connect the Xbox One pad with the cable it recognises it as Logitech F and sometimes as Generic Xbox One controller meaning I can’t use anything to navigate.

The problem is that a bunch of controllers all show up to the OS as the same thing now. 8bitdo is a big offender here. If the 8bitdo device has different pairing modes, you can usually find at least one of them that reports what it actually is instead of pretending to be some other device, but I would guess the 8bitdo dongle doesn’t really have anything like that.

The only real suggestions I have are: turn on ‘all users can control the menu’ in case your pad gets pushed over to a non-primary port and make sure you launch RetroArch with the device you intend to use rather than the remote, as the remote will jump into the first position and prevent other devices from being there.

Thank you for your response.

I actually decided to roll back to an earlier version where I wasn’t having these issues (1.77) but now I’m facing an odd issue as a result of the rollback where the game names are not matching up correctly ie The game in the FBA list will say Final Fight and have the Final Blow Artwork. I assumed the artwork was just mismatched. When I run the game it IS in fact Final Blow however, despite it being named on the list as Final Fight. I’ve deleted the FBA playlist and rescanning the Roms folder to see if that fixes it. Will update, but if you have any ideas how to fix please let me know. I genuinely appreciate your help with this.

I think deleting the playlist and rescanning is the best thing to try first.

Thanks, that seems to have fixed it and back to where I was initially :slight_smile:

One last question - is it possible to save different controller configs for different controllers? When I use my Xbox One pad I want the buttons mapped differently to when I want to use my 8 bit so pad ideally. When I remap the buttons under 8 bit do m30 it also applies that to when I plug in my Xbox pad, even though it’s correctly recognising the controller now. Anyway around this?


Not really, AFAIK. We don’t support per-controller configs or remaps.

Ok. Thank you for all your help with this and keep up the awesome work :+1:

1 Like