PowerPC Mac Thread - Bugtesting etc

Hey guys,

My school paper had two iMac G5’s and an iMac G4 laying around collecting dust, so they let me bring them home. I figured I’d find some way to turn them into emulation machines and potentially arcade cabinets, so I was super excited to see that a new build of RetroArch had just come out for them.

So here is my list the bugs I’ve encountered in RetroArch 1.3 on my 2.1 GHz PowerPC G5 with 1.5GB RAM running OS X 10.5.8

[ul] [li]The CPS-2 core doesn’t appear to work at all, it just loads the ROM, goes to a white screen, then crashes RetroArch. I don’t know if I have the incorrect ROM set for this version of FBA, but the same ROMS work on my i386 Lakka box and x64 Windows and Linux machines. [/li][li]Changing to or from fullscreen in any of the frontends causes a crash regardless of windowed fullscreen setting. This problem does not occur when changing to fullscreen from the OS X menu bar or from changing the config file. [/li][li]In the ZARCH frontend, the settings menu is broken, so there’s no way to switch back to another frontend aside from a config edit. [/li][/ul]

That’s all for now. All-in-all this runs pretty great.

Any updates on a build guide, MAME core, XInput support or PPC Lakka? I can’t wait to turn these ancient things into counter-top Lakka arcade cabinets.


The ZARCH menu bug is known and is just a result of it being experimental/unfinished.

dunno about the others.

I decided this week to get back to work on my PPC arcade cabinet, and was excited to see that 1.6.0 had a PPC release, but I’m having one significant issue with this version that wasn’t in 1.3.0.

I have a generic playstation-style USB Gamepad that has a very generic device id and manufacturer id (input_vendor_id = 121 input_product_id = 17). It works perfectly fine in 1.3.0, but in 1.6.0 only two of the face buttons (Triangle and Circle) are recognized, and they read as buttons 0 and 8 as opposed to 0 and 4 in 1.3.0. Copying over my autoconfig file from 1.3.0 to 1.6.0 doesn’t do anything, as 1.6.0 seems to only recognize those two buttons, not responding at all to the other face buttons or shoulder buttons.

The issues with going fullscreen from UI and CPS-2 core are still around.

If anyone has any ideas about the controller thing, I’d appreciate the help.



I tried some versions of retroarch for ppc and cant get any to work. With the latest version 1.6.3. i just get a totally black screen, then i have to press escape to quit. It seems to be some problem with the “video”, because with other previous version, i get a white screen where one can barely distinguish the menu options e navigate them. I also build the the project in the corresponding xcode version, it builds and runs to give me the same black screen, but i noticed the existence of some warning messages related to video.

I am using a mac mini g4 ppc @1.5Ghz with 1GB of ram and 64 Mb video. Is it supported ? Could not find any requirements.

Appreciate any tips from some who had similar situation.


Try changing the menu_driver to “rgui” in your retroarch.cfg.

hi, tank you for the tip. i did manage to change that setting to rgui, after some research e believe it would bring old interface, but unfortunately it doesn’t happen. still getting the same black screen. :frowning:


I just noticed the download link on http://www.retroarch.com/index.php?page=platforms for PPC builds doesn’t work. (https://buildbot.libretro.com/stable/1.6.9/apple/osx/ppc/RetroArch.zip)

There’s no PPC folder in the nightlies either https://buildbot.libretro.com/nightly/apple/osx/

Was support dropped or something?

No, support hasn’t been dropped, AFAIK, but I suspect our buildbot just isn’t set up to build them anymore.

Is it going to be fixed or was it intentional?

Not exactly intentional, but I’d say it’s probably pretty low priority right now. That might change if/when we start working on MacOS 9 support (there’s no telling when that will happen, though).

In the meantime, you’re probably best off just building on your own, which isn’t too difficult as far as those things go.

hey, i was wondering if there was ever a resolution to @pfmc problem with the mac mini displaying a black screen? I’m trying to run the latest available PPC build of retroarch on a 1.42ghz G4 mini running 10.5.8 and i’m experiencing the same issue - totally black screen, even after trying the “rgui” fix mentioned earlier in this thread. i’m able to load both cores and content (i know that my ROM has successfully loaded because despite the black screen, i can hear the game’s music/sounds playing perfectly), but no luck with actually seeing anything as of yet. graphics card is a Radeon 9200, other hardware info provided below.

any thoughts/fixes?

thanks in advance!Picture%201

Ftr, same thing happening with my Mac Mini G4 (late 2005, 1.5 G4, 64 MB Radeon 9200 (remember, NOT a true R300 GPU). Video or menu drivers do not help. Only other somewhat modern Mac I own is an early 2006 Mini that I swapped a Core 2 Duo T7200 into.


I am trying to breathe new life to an old eMac G4 1.25GHz. I tried the oldest RetroArch available as well as the latest build 1.8.3 but they both displayed a black screen on start. I know the application is working and is on the xmb gui because i tried fiddling around in the menus while doing the same keypresses on another Mac and the thing i did worked. I updated assets, i loaded content and the music was playing. I tried editing the configuration file in User/xxxxx/Library/Application Support/RetroArch/Config, changing xmb to rgui but that did nothing, black screen still…

This old eMac has a ATI Radeon 9200 which is not in the R300 family of cards, i think it can do pixel shaders 1.4 but i read in other places that in Leopard i was maybe dumbed down to 1.3. Anyway i am just speculating that my black screen problem is related to that.

Anything else i could try to resolve this problem? It would be wonderful to be able to use an emulation power house such as RetroArch on old PPC machines.

Try changing your menu_driver to “rgui” in your retroarch.cfg. You might also need to change your video_driver to “sdl2”

I tried changing video_driver to “sdl”, “sdl2”, i still get a black window. I tried changing from “xmb” to “rgui” and that also did not work.

hmm, if those didn’t get you anything I’m not sure what else to recommend.

Hello again

Well the problem is with the graphics card, the Radeon 9200 is just too old i guess and must be missing some important feature (probably pixel shaders are too old). I tried RetroArch 1.8.3 on my PowerBook G4 that has a Radeon 9700 and it works and displays the interface properly.

But RetroArch 1.8.3 on Mac OS 10.5.8 is really unstable, it does not take a lot to make it crash. Just trying to go fullscreen freezes the application, lots of things in the menu makes the application crash. Is there a known to be stable version for PPC macs?