PPA Testing in Ubuntu 22.04.3 LTS

I have encountered a problem with the PPA.

When upgrading I got a warning, that retroarch was not retained.

It asks for libflac12 to upgrade or to install
" retroarch : Depends: libflac12 (>= 1.3.0) but not installable "

Hmm, that’s weird. That’s not one of the dependencies. libflac-dev is, though: https://git.launchpad.net/~libretro/libretro/+git/RetroArch-debian/tree/control?id=639e69ee4755fbbd2748d558e83ca986eebe162e

I installed libflac-dev and it installed these two, libflac-dev libogg-dev


Retroarch keeps telling me the same thing.
Captura desde 2023-08-10 01-02-44

I search for libflac and I get this.
Captura desde 2023-08-10 00-02-43

Could it damage the system?

No, it won’t break your system to install libflac.

I’m still confused as to where it’s getting this libflac12 dep from, since it’s not in the package’s debian/control file, and libflac12 doesn’t appear to be a real package anyway.

libflac12 is in lunar:


1 Like

Not so much the library alone, I am afraid that I have several ppa’s and maybe one of them will interrupt.
I meant that maybe I broke the system by installing some PPA (I have some), that happened to me some time ago with kdenlive, I changed a library and left out flowblade and a couple of others…

libflac12 is in ubuntu at lunar and mantic and in debian in the 3 branches.

What uses flac codecs, other than audio-video capture or playback?
I understand that whatever “dev” is not a library as such, but installs the latest version in development.

why you have a Daily Build of ubuntu , better the stable 22.04.2 anyway ?

precisely, for early testing and bug reporting, prior to stable.
I am an unofficial beta-tester

No, -dev packages are the development headers and other files required to build software that use those libraries.

The RetroArch package you are trying to install is not for jammy, that is all.

1 Like

I understand…

I know this, but why does RetroArch ask for it, and also prevents installation, is the dilemma.

As I said, the retroarch package you are trying to install is not for jammy. What ppa are you using?

This is the control file for the retroarch package for jammy from the testing PPA, looks OK to me, requires libflac8:

Package: retroarch
Version: 1.15.0-r202308100647+d0d1321ac1-168~ubuntu22.04.1
Architecture: amd64
Maintainer: Libretro Team <[email protected]>
Installed-Size: 19859
Depends: libx11-dev, libxrandr-dev, fonts-dejavu-core, libqt5waylandclient5, libvulkan1, libasound2 (>= 1.0.18), libass9 (>= 1:0.13.6), libavcodec58 (>= 7:4.4), libavformat58 (>= 7:4.4), libavutil56 (>= 7:4.4), libc6 (>= 2.34), libcaca0 (>= 0.99.beta17-1), libdbus-1-3 (>= 1.9.14), libdrm2 (>= 2.4.62), libegl1, libflac8 (>= 1.3.0), libfontconfig1 (>= 2.12.6), libfreetype6 (>= 2.2.1), libgbm1 (>= 8.1~0), libgcc-s1 (>= 3.3.1), libgl1, libjack-jackd2-0 (>= 1.9.10+20150825) | libjack-0.125, libopenal1 (>= 1.14), libpulse0 (>= 0.99.1), libqt5core5a (>= 5.15.1), libqt5gui5 (>= 5.2.0) | libqt5gui5-gles (>= 5.2.0), libqt5network5 (>= 5.14.1), libqt5widgets5 (>= 5.15.1), libsdl2-2.0-0 (>= 2.0.12), libsixel1 (>= 1.10.3), libstdc++6 (>= 11), libswresample3 (>= 7:4.4), libswscale5 (>= 7:4.4), libudev1 (>= 183), libv4l-0 (>= 0.5.0), libwayland-client0 (>= 1.20.0), libwayland-cursor0 (>= 1.12), libwayland-egl1 (>= 1.15.0), libx11-6, libx11-xcb1 (>= 2:1.7.5), libxext6, libxinerama1 (>= 2:1.1.4), libxkbcommon0 (>= 0.5.0), libxrandr2 (>= 2:, libxv1, libxxf86vm1, zlib1g (>= 1:1.1.4)
Provides: retroarch-dbg
Section: games
Priority: optional
Homepage: https://www.libretro.com/
Description: Simple frontend for the libretro library
 RetroArch is an open source, multi-platform frontend for the libretro API. It
 can be used as a modular multi-emulator system, game engine, media player and
 3-D technical demonstration. These features are available through libretro
 It provides four built-in graphical user interface flavors: RGUI, XMB, Ozone
 and GLUI.

Did you read from the first comment? I already explained that.

Yes. As far as I can tell, you are not using the appropriate repository. See my previous post.

@hunterk Have you already repaired it? :flushed:
I just installed it successfully.
The following NEW packages will be installed: libqt5waylandclient5 retroarch

Curiosity, install 1.15.0 and when I open it is 1.16.0


EXCUSE ME? Do you know how many years I have been using the repository?

You read the message I wrote. I was using it and it didn’t update.

How are you going to say that the testing repository is not for Ubuntu JAMMY?

Hey, not a big deal. That’s why I said as far as I can tell.

Anyway I was indeed wrong. I checked the previous build and the dependency was libflac12, so it’s not good that the PPA can seemingly randomly change dependency versions.

Better to build from source IMHO. Cheers.

1 Like

Here is the buildlog from the failing build:


The problem is that it used a backported libflac package (and also others) from the Rob Savoury PPA (no idea why). If it happens again, you can check where the required packages are from in case they are missing.

Still, weird that the build system uses packages from PPAs, but maybe this is normal.


To say that PPA Testing is useless in Ubuntu LTS is an unforgivable mistake!
It’s all right, it’s the dynamics of the forum. :grin:

But how is it possible that it can randomly change and select a library that does not exist?

Some time ago something also curious happened to me, I was trying to install gnome-games when I was installing retroarch.
edit: This is why I asked if maybe I had broken something with a PPA.

I read about 50 pages about this problem, and only one (in Spanish) said that when the “broken packages” warning comes up and there are no broken packages or installation candidates, the best thing to do is to wait, and in a couple of days it will be fixed.