Prioritizing Controllers for User 1


#1

Until recently, I’ve been using an xbox 360 controller. However, I finally purchased the xbox one adapter for Windows and started using that controller, instead. Everything works exactly like the 360 controller, except when I have a 360 controller turned on as well. When I start a core in this scenario, the 360 controller automatically gets mapped to user #1 and the xbox one controller gets mapped to user #2. I’m fairly certain it has something to do with my Xinput_Controller_User_1.cfg file that I modified in order to map the guide button to open/close the menu. If I’m correct in that assumption, how would I modify these cfg files in order to always give a detected xbox one controller priority to user #1 and keep my guide buttons mapped to menu? (I realize that only player #1 can open the menu, and I’m fine with that.) In short, this is what I’m trying to accomplish: Any detected xbox one controllers have user assignment priority over any xbox 360 (or any other) controllers.


#2

After playing with this for a few days, I don’t think the cfg file is the culprit. If only the xbox one controller is turned on, it will get designated to User 1 (port 0). However, as soon as I turn on one or more xbox 360 controllers, they take priority and the xbox one controller gets bumped down to the last available user/port. I’m trying to accomplish the exact opposite of this. In other words, I want any detected xbox one controllers to get the first dibs on user 1 (port 0), user 2 (port 1), etc…


#3

That’s windows for you


#4

I don’t have a fix for this but I’m kind of in the same boat and am curious if my workaround works for you?

In my case I have 4 wireless controllers. When I have a game and core already running it just seems like whatever controller is connected last becomes User1\Input 0 (i.e. Player 1).

Not sure if this is a bug or a feature as I recall there were people who wanted to be able to swap from a controller to an Arcade Joystick by adding the joystick _after_running through all the menus with a regular joy-pad.

I think in 1.7.3 the opposite was true as I only noticed this behavior after updating to 1.7.5?

Have you tried starting your game/core with the 360 controller then powering on the XBOX One controller to see if it becomes User1\Input0 as a workaround?

EDIT: Whoops didn’t see radius’ post.