Problem configuring XBox One controller


#1

Hi,

I have setup Retroarch to use my SNES USB controller by default (menu and most cores : NES, SNES, GBA etc.), but for the Reicast and PSX cores I’d like to use my XBox One Controler. The problem is that everytime I launch a Dreamcast or PSX game, I have to remap the controls ; I go to Config -> Input -> User 1 Binds ->" User 1 bind defaults all" and then the controller works as expected, every button is mapped correctly ; but then after saving the core override, I can still navigate the Retroarch menu with the XBox One controller D-pad, but the buttons don’t work anymore. If I quit the game and try to launch it again, the mapping is not saved and I have to do it again.

Is this a known bug ?


#2

I’m not sure what’s going on in your particular situation, but if the xbone controller is recognized and autoconfigured you can either unplug/replug it when you want to change cores or you can leave it plugged in all the time and go into settings > input and change the device index to it when you want to use it. It seems you can change device indexes with overrides, as well, according to a recent thread where someone was using them to do the same thing you’re wanting to do.


#3

No, if I change the device index to select the XBox One controller, I have to map all the buttons again. The configuration is not saved.


#4

Ok, if you configure it and then save the autoconfig profile, does it actually create a file in your autoconfig directory?


#5

Yes, it does create a file named “XInput Controller (User 1).cfg” in the autoconf\xinput directory.

This is what’s in it :

input_driver = “xinput” input_device = “XInput Controller (User 1)” input_b_btn = “0” input_y_btn = “2” input_select_btn = “7” input_start_btn = “6” input_up_btn = “h0up” input_down_btn = “h0down” input_left_btn = “h0left” input_right_btn = “h0right” input_a_btn = “1” input_x_btn = “3” input_l_btn = “4” input_r_btn = “5” input_l2_axis = “+4” input_r2_axis = “+5” input_l3_btn = “8” input_r3_btn = “9” input_l_x_plus_axis = “+0” input_l_x_minus_axis = “-0” input_l_y_plus_axis = “-1” input_l_y_minus_axis = “+1” input_r_x_plus_axis = “+2” input_r_x_minus_axis = “-2” input_r_y_plus_axis = “-3” input_r_y_minus_axis = “+3” input_menu_toggle_btn = “10” input_b_btn_label = “A” input_y_btn_label = “X” input_select_btn_label = “Back” input_start_btn_label = “Start” input_up_btn_label = “D-Pad Up” input_down_btn_label = “D-Pad Down” input_left_btn_label = “D-Pad Left” input_right_btn_label = “D-Pad Right” input_a_btn_label = “B” input_x_btn_label = “Y” input_l_btn_label = “LB” input_r_btn_label = “RB” input_l2_axis_label = “LT” input_r2_axis_label = “RT” input_l3_btn_label = “Left Thumb” input_r3_btn_label = “Right Thumb” input_l_x_plus_axis_label = “Left Analog X+” input_l_x_minus_axis_label = “Left Analog X-” input_l_y_plus_axis_label = “Left Analog Y+” input_l_y_minus_axis_label = “Left Analog Y-” input_r_x_plus_axis_label = “Right Analog X+” input_r_x_minus_axis_label = “Right Analog X-” input_r_y_plus_axis_label = “Right Analog Y+” input_r_y_minus_axis_label = “Right Analog Y-” input_menu_toggle_btn_label = “Guide” input_up_axis = “-1” input_down_axis = “+1” input_left_axis = “-0” input_right_axis = “+0”


#6

hmm, i guess the question is why it’s not picking up the xbone pad autoconfig that we already ship: https://github.com/libretro/retroarch-joypad-autoconfig/blob/master/xinput/Xbox%20One%20Controller%20for%20Windows.cfg Have you tried updating your autoconfig profiles from the online updater?


#7

I have an XBOX One elite controller and it uses the proper device ids on Win10 anniversary. Before that (Windows 8.1 for instance) it used the exact same ids (thus mapping) as the XBOX 360 controller


#8

[QUOTE=hunterk;48780]hmm, i guess the question is why it’s not picking up the xbone pad autoconfig that we already ship: https://github.com/libretro/retroarch-joypad-autoconfig/blob/master/xinput/Xbox%20One%20Controller%20for%20Windows.cfg Have you tried updating your autoconfig profiles from the online updater?[/QUOTE]

Yes my autoconfig profiles are up to date.


#9

Does autoconf work at all for the xbox360 pad? ie, if you default everything, does it work?


#10

I’m running the latest stable Lakka – there appears to be no way from the GUI to update the autoconfigs. I cannot currently get any controllers to work, only keyboard, on a fresh install (x86, linux). Any suggestions? Aloha.


#11

I can’t manage to get my xbone elite controller to work properly. A X Y B and the triggers won’t map anything. Any suggestions? Also I’m on windows 7. Thanks friend.