Problem with controller on Fuse core

Hi I have not Controller usage on Fuse core menù when I load game, so I can not change types of joystick and can not play. Someone can help me? Thanks Jeosh

please, can someone help me?

I tried getting the controls to work with fuse as well, and I couldn’t get it working. I did find that you can use a dos spectrum emulator under DOSBox. I found that the following emulator works under DOSBox:

http://www.worldofspectrum.org/warajevo/index.html

I found that setting the cycles to 4000 worked best for me under “Options”. Unlike fuse, this emulator also has the capability to save states as “.z80” files.

-Andrew

Thank you, I solved using an old version of retroarch, where controllers work! Jeosh

Having the same issues with 1.7.5 & 1.7.7. I have tried creating all configs afresh and still no joy. Any help would be much appreciated.

What version did you go back to. Can’t recall the version I was on. Thanks.

Excuse me, I read only now your question. I use 1.6.7 and it works, I don’t understand why also in 1.7.8 there is still this problem.

also in 1.8.5 version, as all the other versions after 1.6, there is still this problem, in device type I can’t change from retropad, and it’s impossible to play on spectrum games, who know how to solve?

Did you only try to configure via the core controls menu? If yes, have a look a the RA input settings instead after loading a game, because judging by behavior on Windows, you basically need to configure the controls there first, because the core’s behaviour doesn’t match others.

yes I try to configure via the core controls menu, and in 1.6 works! also in the RA input setting I can’t change Device Type, I need to use Spectrum keyboard, that is critical for start games

You can’t change port 3 to the Keyboard?

how can I do it? I’m not very pratical

In the RA input (NOT core controls) settings, the max user number (I think this is 5 by default) define the number of ports. Port 1+2 are reserved for the Spectrum Joysticks, port 3 should normally allow switching to the sinclair keyboard. You may also have to go the core controls afterwards and set it there also.

I don’t have an Apple device, so I don’t know what other options there are, maybe you can also change the input driver, and see if that makes a difference.

Also in RA input setting, I can’t change port 3. How can I change input driver? It is strange, al 1.6 version it worked perfectly!

Input drivers can be changed in the Drivers menu or in the config, have a look around to see what’s possible on your device.

input driver is cocoa, the same of 1.6 that work, and there isn’t any other. Please help me :smiley:

I’m out of ideas, I guess it’s a platform specific bug then.

There’s talk about the problems on github:

Maybe you could try changing the input directly in the retroarch.cfg instead from the gui.

input_libretro_device_p3 = “259”

ok, maybe the only soluction is to install also the 1,6 version only for gaming at spectrum. I will try your suggestion about changing cfg, but I think that it is not enough to activate keyboard, because in spectrum need other config (cursor joystick, Kempston joystic, sinclair 1 Joystick, sinclair 2 Joystick, timex 1 joystick, timex 2 joystick, fuller joystick) that are in 1,6 version. Thank you for spending time! :slight_smile:

I just tried to change config/retroarch.cfg with input_libretro_device_p3 = “259”, but nothing happen! In RA settings/input/Port 3 Binds, there is “device type Unknown”