Problems mapping N64 buttons (Help!)

Yes I closed out and went back in. What is the core plus content? I see nothing else to do when mapping the buttons. Where am I supposed to go? Back into the mupen64plus options?I don’t see any other options when mapping the controller…

That option subtly changes the way the quick menu > controls menu works. It won’t really look any different, but the c-buttons will actually remap properly.

“core plus content” means… the core (mupen64plus-next) and the content (the game).

It didn’t work or do anything. I remapped the c-buttons over and over again to the right analog and other buttons. And nothing. The c-buttons are acting like left analog stick and I don’t know why. Thing is I was using them as c-buttons not too long ago.

Why does it have to be so difficult to map a few damn buttons?!

I have no idea what you’ve done so far, but you can delete config/[corename] directory and it will get rid of any remaps and core option files to return the core to its normal state.

Have you done anything in settings > input? If so, you probably want to open your retroarch.cfg and delete all of the lines that start with ‘input’ to return your input settings / mappings to default.

Yes, I have done a lot of mappings in settings > input. But when I open up retroarch.cfg there are like 200 input files. So, just delete them all? Which input files have to do with the mupen64plus mappings?

None of them have anything to do with mupen64plus-next, specifically. The retroarch.cfg is your general/global config. Things you do in settings > input go into it, and those changes affect all cores.

Settings > Input affect all cores. It’s the “retropad” config. Treat it as the basic, default option. This is saved in the main config.

Core Options > Controls is where you change specific controls for the opened core. There is a “remap” subfolder in the “config” folder where all these saved configs are kept.


I tried deleting the config/mupen64plus-next directory and that did nothing. I tried deleting all retorarch config files completely and that still did nothing. I deleted the remap subfolder in the config folder and nothing. I still can’t map the c-buttons and the c-buttons are still acting like left analog inputs.

So, I’m trying to use a USB N64 gamepad. I go into normal retrorach settings inputs, port 1 controls and map the buttons to my USB N64 controller and I map the C-buttons to right analog up, down, left, right. When in game with Mupen core running, I go to the mupen64plus core options>controls and try to map the c-buttons to right analog. I can get every button to work except the c-buttons. When mapped they just act like a duplicate of the left analog…

if you mapped the retropad’s right-analog axes to your gamepad’s C-buttons, you shouldn’t need to do anything in quick menu > controls because that’s where they’re mapped by default.

I did, so then why are they not registered as C buttons and are acting like a duplicate of the left analog?

No idea.

You can look at how one of the other N64 pads has been mapped to see if you used a similar scheme:

That’s exactly how I mapped mine except the c buttons are acting like duplicate left analog input…So everything is working for me except the c buttons…

I just tried an xbox 360 controller and every button worked but the c buttons. I can even confirm that all buttons: a, b, L, R, Z Start, Select all work on the “right analog stick” as well as the left. So both analog sticks are functioning. The C buttons are the only inputs that do nothing on the right analog stick? How did this happen and is there any way to fix it?

Also, what is c buttons mode?

If the “independent c-button mapping” option is not enabled, retropad-R2 will move all of the c-buttons up from the right-analog onto the 4 face buttons (ABXY) for as long as you hold it. This is to help with precision, since it can be hard to play ocarina songs (for example) on the analog stick.

I fixed my problem. The C buttons are now working. What I had to do was actually delete the actual game file (Conker’s Bad Fur Day (USA).srm) found in the saves folder. I remapped the buttons to my Xbox 360 controller in the regular retroarch input settings and when I loaded up the game the buttons were automatically mapped to the 360 controller, including the C buttons!

When I tried the same thing with my USB N64 Controller, the C buttons worked but all the C buttons also had other actions assigned to them along with the cameral controls. Which is weird…

But anyways the Xbox 360 Controller works perfectly!

1 Like

hmm yeah, weird, but all’s well that ends well! I’m glad you got it fixed up and thanks for following up with your solution :slight_smile:

I’m just wondering, why would my main save file be linked to the button mapping errors?

Does the game have it’s own, native control options?

Maybe you changed something there and your changes got saved in the native game save. So by deleting it, you got the defaults back.

No I didn’t change any in-game controls at all…And why do the c button default camera controls, up down, left, right, also have the A, B, Z , R mapped to them at the same time, when I try to use my USB N64 controller?

Like I’ll push c button up and the camera will move up but I’ll also attack at the same time. And I’ll push c button down and the camera will move down but I’ll also jump…

are you able to press C-up and C-down at the same time? I’m having the following problem ParaLLEl N64 - cannot use both C-up and C-down at the same moment

which seems to be similar to yours