PS1 Disk changing problem

hello, i’m trying to play crono cross and i’m having some problems with disk changing, every time i try to change the game disk, the emulator just resets instead of just resume the game…

i’m using the PCSX ReARMed core and checked the docs for multiple-disk games and swapping disks

already tried using a .m3u file but it doesnt load when i select it, tried both writing only the .cue file names and also with the full path to the files…

also, i’ve checked other similar treads but found no solutions for that.

only thing i can think of to surpass this problem is to use savestate in the disk change window, then change the SS file name for disk 2, load disk 2 and use a loadstate, but that would require me to connect my phone to my pc just to change the file names every time i would do that…

only thing i need is to change disks without reseting the game… tnks

Go to settings > directory and set your file browser setting to literally anything other than “default” and see if that fixes it.

1 Like

it is working now, tnks bro

sweet. I’m glad that got you fixed up.

That’s a weird, longstanding bug that we haven’t been able to track down, though I thought it was fixed awhile back. Evidently not :man_shrugging:

Im having a similar problem with chrono cross. In my case when i change the disc the game closes the virtual tray but doesnt continue. Any one knows how to solve this?

I answered in the other thread:

It still doesnt work, i did open the tray resume the game and then open the menu again and changed the disc and still nothing happend. Do i have to change some configuration to make it eork?

I tested with my Android phone, ReARMed core and Chrono Cross (USA).m3u . Still works on my side.
Can you check if the entries in the *.m3u are correct?

Another possibility is to assign hotkeys for “Disc Eject Toggle”, “Next Disc” and “Previous Disc” in Settings - Input - Hotkeys
so that the game doesn’t pause when you are changing discs.

@hunterk: is it possible to merge the thread i linked in my post above with this one for more clarity? Thanks in advance.

Is there a way to assingn hotkeys with the virtual pad?. If you whant i can show an image of the *.m3u. ![Screenshot_20200728-081839|237x500] (upload://ej6oPitjmtlM0tarLTtGNFNimnS.png)

And some times after i try to change the disc and the game doesnt resume and i restart, retroarch automaticly loads CD2 and the game works the problem is when i try to load the last game with the memory card, the gane asks to place cd 1. And when i try to load the last save state the game crashes. When the game crashes i have to erase the *.srm file because the game keeps crashing afterwards.