Questions about ecwolf core on PS2

Hi, everybody. Brand new user here. I use RA a lot on a Raspberry Pi and a Windows laptop, and I just put the PS2 port (v1.13.0) on my fat PS2 that runs FreeMcBoot. So far I’ve only been interested in the prboom and ecwolf cores. Prboom works well and I’m not having any problems with it (so far). I understand the ecwolf port is still a WIP and I have a few questions that I hope someone familiar with it can answer.

  1. Supposedly the save and load function is in the RA menus but I have not found it, I only see the save/load state options. I also do not see it in the Windows version.
  2. I am not getting any background music, and the core settings does not have an option for music volume. I briefly tried the Windows version with the same WL6 data and the music plays and the core settings has an option for volume.
  3. It supports the .pk3 extension which is used for many mods and addons, so is there a way to enable some addons akin to the -file commandline argument or an autoload folder.

Thanks in advance

Update: Since my initial post I’ve gotten the latest retroarch, 1.15.0 but cannot get the ecwolf port to load at all. I tried the core included with the 1.15.0 release, with the latest ecwolf.pk3 and with the version from 1.13.0. In both cases the settings indicate the pk3 is present and shows the md5; however, the core fails to load, RA exits to the memory card screen, and I have to delete the retroarch-salamander.cfg file for RA to start again. I then tried the core files from RA 1.14.0 and the latest nightly with both versions of ecwolf.pk3 and got the same result. With RA 1.15.0 and using the ecwolf core and pk3 files from 1.13.0 it works.

Is this a problem with newer versions of the core and my console? IIRC mine is a V5 SCPH-30001. Or is it a problem with the ecwolf.pk3 file? I only have the version from when I download 1.13.0 last month and the current version with datestamp 05/10.