RA 1.14.0 crashes with some cores

when I try to load ROM with some cores (tried with PS2/GameCube/Dreamcast) RA crashes. Here’s the log file. And this is my config file

  • OS: Devuan GNU+Linux Daedalus
  • Retroarch: 1.14.0

SNES/PSX/Saturn roms work.

Any idea ?

try using the vulkan video driver with those cores.

I haven’t got vulkan video driver in the list. Only :

  • gl
  • gl1
  • sdl2
  • xvideo
  • x11

None of these works.

Hmm, how did you install RetroArch? from their package manager?

Yes, I installed it the CLI.
sudo apt install retroarch
Depends packages and recommends packages are installed too.
I’m using a window manager, not a desktop manager, launched by the startx command. Don’t know if it’s important to say.

okay, while RetroArch is running, try to going to main menu > information > system info and see if ‘vulkan’ says “yes” or “no”. That will tell you whether it has vulkan support compiled in or not.

It’s interesting that it doesn’t have glcore listed in the drivers either :confused:

You might have better luck with our AppImage: https://buildbot.libretro.com/stable/1.19.0/linux/x86_64/

You can also try running directly on the console without X running.

It’s compiled without vulkan driver.

I don’t use AppImage ^^’

I tried on the console without X running and nothing happened.

Probably need to wait the next release of Devuan to get these cores working if they need vulkan driver. Or I’ll try compiling it with this support from the source.

Thanks :smile:

heh, why no AppImage? i’ve heard people ideologically reject snap for fairly legitimate reasons, but never AppImage.

It’s not my philosophy to download softwares from the web for everything I want. There’s repos and package managers, it’s simpler. I can try the flatpak, though.

1 Like