RA not "passing" input mapping to Mame-2003-plus core

Hi, So I have Launchbox running with RA on Windows 10, ver 1.8.4, works fine for the most part but I am noticing that Mame 2003 plus is not picking up my input mapping.

I have everything for Player 1 and 2 setup in RA under “Settings - Input”. I also confirm the input settings look fine when launching a game and going into “Quick Menu - Controls”

But when I press TAB in Mame, go to “Input (General)” it does not match up. I thought RA was supposed to ‘hand’ Mame-2003-plus all the controls, so I don’t have to set anything in Mame itself?

A good example, for Player 2 Up/Down/Left/Right in the Mame “Input (General)” it lists ‘r f d g’ for up/down/left/right. I never set that anywhere I know of, it almost seems it is using keyboard controls now for this core for player 2.

I have tried to delete nvram files under saves, cfg files, core overrides, been honestly working on it for 3+ hours and I am SURE there is something easy I am missing.

OH - and I have tried under RA “Quick Menu -> Options” once in a game to set “Legacy Remapping” to OFF vs ON. Does nothing.

Would appreciate any help, even if it means having to set Mame -> TAB -> Input area for all controls, but again I thought that was the big reason to use RA so you don’t have to do that.

Just noticed one more thing - tried to play with Input Interface under Options, not sure this means anything?

(BTW I am using Ultimarc iPAC connected to Joysticks and buttons, a standard setup.)

So I went into:

“Quick Menu -> Options -> Input Interface”

If I set to Keyboard, nothing works including my actual keyboard (no TAB in Mame, etc.) If I set to Retropad, nothing works If I set to Simultaneous, then joysticks / buttons work like normal but again mapping is off.

Thank you!

I use an I-PAC in one of my control panels, along with mame2003 via Lakka and you shouldn’t need to mess with the MAME OSD controls at all. If your inputs are all mapped to the retropad properly, the core controls are mapped to the retropad by default (at least for the 4 joystick directions and buttons 1-8).

That is what is so strange, I have no idea how to set 2003-Plus to use my input settings, not sure where it is getting the random inputs from.

It doesn’t really matter what the MAME OSD mapping says, as the core has a layer in between that is taking the retropad inputs and turning them into things the core understands.

While you’re in the MAME OSD, if you try to assign a button, what does it report it as? Or does it not recognize any inputs then either?

I can assign buttons in MAME OSD, and there are ones already there. They show

RP1 HAT UP for P1 Up etc.

I did another test and one example is, in Mortal Kombat and other games, if I press P2 Coin then press right or left, its as if I pressed “B” button to select character. Then when playing, if P1 presses a direction its as if I pressed B, Y, A or some buttons on player 2. What a mess…was not always like this, was working fine after initial install.

I also noticed in MAME OSD, these are some strange input mappings

P1 Right/Up RP2 Up and so on

P1 Right/Up RP4 Up and so on

Also AD Stick, Lightgun and others are mapped to RP1 or RP2 directions

Thank you for all the help

I am wondering if this started when I got the AimTrak lightgun, maybe I messed up an input setting or played with MAME OSD directly.

If this is a lost cause I can reinstall RA, would just need to re-do input and overlays / bezels I believe.

Luckily, there’s not usually any need to completely reinstall RA because everything gets stored in config files within RA’s own directory instead of sprinkling things around in the registry and whatnot.

With that in mind, I would suggest doing some sanity checks: take your retroarch.cfg and move it somewhere else temporarily and see if that fixes things. If so, your problems lie in there. If not, move on to something else, like retroarch-core-options.cfg, or stuff in your config dir (remaps/overrides).

I appreciate the help and ideas, tried those and no luck.

Might just start using Mame 2003 for all my roms and possibly just move away from RA

Too bad because I really like it, just a lot to deal with and figure out.

After playing with it, I may just configure MAME OSD General input, it seems to stick and if I use that method everything works fine. Not sure how MAME input is overriding RA input but I am fine with it.

If you think of any other reason for the behavior let me know I will give it a shot

Thanks again!

1 Like