Rare? Hotkey Issue on Windows 10 Retroarch PC -

I’ve been searching for a solution for months so please redirect me if there’s already an open thread for this.

I’m running latest Retroarch on PC w/ windows 10. Issue is when I load a game, regardless of core/platform, I’m able to execute hotkey commands once, maybe twice before the hotkeys become unresponsive during each session. I’m using SF30 Pro and I use ‘select’ as enable hotkey. The only workaround I’ve found is the RGUI option to use a button combo to open the menu, in this case L3 + R3, but its becoming a pain in the ass having to do that every time the hotkey stops working. Start + Select to exit still works oddly, just can’t do anything else when it craps out. Again this happens per session, so hotkeys work at the beginning then stop. Hopefully all that makes sense, let me know if I need to elaborate.

Thanks,

I actually created an account to try to further this discussion. I’ve been having the same issue with RetroArch on Windows 10.

What I’ve noticed is that it only stops responding when I use the Menu toggle hotkey to close the RetroArch menu. If I close the RetroArch Menu by selecting “Resume”, everything works just fine. But once I hit the Hotkey for opening/closing the menu, RetroArch stops responding to all hotkeys (although the game still plays just fine).

So it’s easy to recreate the bug, but I have no idea how to fix it, outside of remembering to manually close the RetroArch menu.

Alright, well, I think I finally figured out the issue, @PrickSlickfield . Just downloaded the latest nightly to see if the issue was fixed, and I still had the hotkey stop responding after using the hotkey + menu combo to close the RetroArch menu. BUT…

When I switched to fullscreen, it opened up with the “Search” menu. It then occurred to me that when I was using my hotkey for closing the RetroArch menu, since I was using the X button on my 8bitdo SF30 Pro, it was opening up the search menu, and then closing the menu , so RetroArch had the focus on the search menu, and therefore, was ignoring any hotkeys!

I checked, and you were having the same issue since you were using Select, which opens up a info window telling you what the option you have highlighted in the RetroArch menu does. It goes to follow that RetroArch goes back to the game, but still has that help window open, and is therefore ignoring your hotkeys.

So the solution is to make sure you choose appropriate buttons to toggle the RetroArch menu so that it no longer does that. I now use the left analogue stick button + Start as my menu toggle, and the X button is now my exit RetroArch button.