Reicast Crashing Retroarch


#1

Recently when I try and load Dreamcast with Reicast Core it just crashes straight away.

I tried making a Log File but it has No Error on it saying what the Problem is.

I use OpenGL as I think that the only Video Driver it will work with.

Not sure what to do to fix it


#2

It worked before you updated the core in the last 2 days right?

Please write your cpu, gpu, operating system.


#3

No it has not. Been Happening when this started:

I am using Windows 10,Intel i5 and Nivida GeFore 1050


#4

The problem has been identified and a fix will be released shortly.


#5

I’m having the same problem. Here. Thanks for the reply.


#6

Thanks @flyinghead. Glad the Problem was Found and Fixed.

Will give it a Test it out later when I done my jobs for the Day

Update

Yep Tried it and Load’s Fine now/

Thanks @flyinghead for fixing the Error/Bug


#8

I tried it last night and the Crashing was back again


#9

I’ve actually never been able to get Reicast to work. I’ve tried with all the video drivers and it just either fails to load content (Vulkan) or crashes completely (everything else). Also have double and triple checked my bios md5s are correct (dc_boot.bin and dc_flash.bin within system/dc).

Also on Windows 10 and currently using the latest nightly of both RA and Reicast core (as of feb 4th).

-edit- just in case here’s my log: https://pastebin.com/2qHc2pqZ -ediit 2- it must be something in my config file since deleting it allows it to load. I guess I could just start over on my settings but that is a bit of a pain. Still at least it’s good to be able to track down the issue.


#10

Hi,

-First of all. Reicast only wortks on opengl backend. It makes use of the opengl 3d renderer for the GPU dreamcast emulatyion. So set your video backend to opengl. -It will require a relatively modern video card with opengl 4.3 support. You might be out of luck if your video card is very old.

In your attached logs, you are trying to use vulkan, that’s why it crashes.

Greetings.


#11

This has been my pet project for a few weeks now. Cubatilles is correct, you need to use the GL driver. Additionally, there are a bunch of BIOS files you need in your System/DC directory to make things happen. Finally, your ROMS need to be “correct” - I am still figuring it out but I am using a combination of .zip files and some other, converted, .bin files and - usually - one or the other will work. Some fall over at the SEGA diagnostics page but that’s not an issue with the emulator. If Retroarch is binning out without even starting up then its usually the video driver or the BIOS files in my experience.

Worst case, some ROMS currently only seem to work with DEMUL so I have my Launchbox point at that instead.

Cheers


#12

Thanks for the reply guys. Indeed it was the fact that I wasn’t using OpenGL, but also there was something funky in my config that caused it to not load. I suspect there was a config option that was added and necessary but not present in my config since it was grandfathered in from years past.

In a bit of a dilemma now though. I want to use Vulkan for most things (such as PSX_HW since due to the awesome SSAA) but obviously that is not an option. --appendconfig with a custom config with just the video driver set to gl for reicast only seemed like an option but I don’t think --appendconfig works. I guess I need to choose either PSX or Dreamcast cause I don’t really want to constantly have to switch between drivers and restarts each time I want to play a different game (I’m going for an idiot proof build since other ppl will be using it).


#13

Works in 1.7.6 Stable Build.

It was not working for me with the late 1.7.5 Nightly Builds


#14

The latest 0.1 9d6f80e Crashes in the Win 64 Bit 1.7.6 Version