Reicast lightgun support for Naomi games


I wonder if the recent lightgun support on reicast works with naomi games (maze of kings, lupin, etc…)? I know it works beatifully with dreamcast lightgun games like confindetial mission or house of the dead, but I haven’t benn able to make it work for naomi lightgun shooters. Maybe it’s a problem of my side, but I’0ve tried changing to lightgun on 1st player device and such with no luck.

I guess it’s not yet implemented. Are there any plans to support lightgun emulation on naomi in the next future? There are a bunch of lightgun exclusive games on the system which were not ported to dreamcast or other systems.


How are you able to Load Naomi Games? Aren’t they supposed to be .dat and .zip Files?

1 Like

You can load them using .lst files (a text formatted file where is defined the name of the edat or bin file containing the game). They are being uploaded here:

edat - .dat or .edat ? Because all of them in the Zip are .dat

Where do I place the LST Files? I placed them with the .zip and .dat Files, but only the .chd Files are showing

Edit: Never mind. Got them somewhat working. They have a Layout of what the NAOMI System Buttons are? Somehow I triggered the System Menu, but could not get out of it.

Most games will no need you tyo enter Naomi service mode, but some games will require ir. For those games, enable the service butons option on core options. Start button will let you enter service menu. The other controls are the standard.

After you enter the service menu how do you select an option? None of the other buttons do anything except the start button, which throws you out of the menu since it has “exit” selected.

There are 2 buttons to use when you are on service menu. The service button and the test button. One of them, the service button, selects the option (move the arrow) and the other one, the test button, confirms. These 2 buttons are mapped by default to L3 and R3 on a xinput pad. I don’t remember which button is assigned to which action. Just try. The start button (which is what you were pressing) acts like the test button (confirmation).


Thanks, i had R3 as the exit button hotkey so there was no way to navigate, i had to disable it to make any changes.

However, i still didn’t find any option in the service/test menu to make Crazy Taxi run normally with it’s attract mode. Instead, it starts with 9 credits by default. How can this be changed?

I think naomi support on reicast has some sort of hack to auto-insert 9 (or more) credits when entering game mode (after the initial setup). That’s how it works with every naomi game on reicast. I guess this was done because coin input was not correctly emulated (just guessing).

So, by now, I don’t think there’s any way you can watch attract mode without inserting credits.


Hi Folks - as lightguns on a PC platform are effectively a mouse has anyone got this working with Naomi? Try as I might I cannot seem to get any Naomi titles to work with a mouse. Other cores (Mame for example) are absolutely fine so I’m assuming its a Naomi issue?

Ah - fixed this one. It wasnt the mouse - just the fact I didnt realise I needed to re-map the Start and Coin controls to GUN Start and Gun Coin as well - plus the seeming random array of Gun Aux button controls depending on the title.

Question though : Can we save custom controls per title? or just per core?

Would TouchScreen/Mouse Enabled work?

I have the same problem, I can’t get mine Aimtrk for the core of reicast, il mouse On the menu works But in games No. Has anyone managed to configure it?