RetroArch 1.7.1 for OGXbox display problem

I’m super excited to see that a new release for RetroArch dropped for the OGXbox! I loaded it this morning to test, and I’m having an issue:

The display is scrambled on launch. Nothing is legible. It’s a problem i’ve had with some other individual emulators before and couldn’t figure out how to fix. Is there anything i can do to fix the display? Possibly in a config file?

If a photo helps, I can attach one later when I get back home.

1 Like

yeah, a photo would be helpful.

1 Like

Sure, here’s what it looks like after launching: I have other emulators that work fine though, so I’m not sure what’s going on here?

1 Like

Hmm, that looks like it’s out of sync to me. I wonder if it’s pushing a bad resolution or something…?

1 Like

Is there a specific value in the retroarch.cfg I can change to address this? I’m looking through all the variables for video and there’s a ton of them. None of them jump out as the resolution setting though.

typically, it’s video_fullscreen_x/y, but I’m not sure if they apply here. I don’t know much about this port, unfortunately.

1 Like

Thank you for the lead! There are “video_fullscreen_x/y” settings, but when i modified them to my screen resolution, it didn’t change anything. I also tried messing with “video_driver”, “video_aspect_ratio” and “video_refresh_rate”, but couldn’t get any different results. Although i was guessing at all of these, so maybe I just tried wrong values? There are tons of other video settings too, but I have no idea what may be useful to try. Dang. I was looking forward to using this.

1 Like

How is your xbox connected to your display? if composite, you might try setting those values to 320x240. /shrug

Sure thing, I’ll try those values next chance I get. I’m connected via composite, but I also have a regular 3-pin a/v cord i can try. This and any other guidance is greatly appreciated!

I have tested it on a Xbox v1.0/v1.1, apparently on some later Xboxes with different video encoders it leads to a weird picture.

I don’t know anything about that, and I am also not able to test this since I only have this Xbox, so I would need more homebrew coders to start helping me here. Are they any left on emuxtras that want to help?

Ok, so I tested swapping out the composite 5-pin cable with the 3-pin a/v cables and it displays correctly. Does that help pinpoint any configuration settings? Resolution settings and aspect ratio seem to be irrelevant. I’d like to use the 5 pin if possible, but as soon as I swapped back, it scrambled again.

I have been messing with video settings, and I haven’t found anything that can make the difference. Is there a reason that a different video encoder would work with a 3 pin cable but not a 5 pin? it’s making me crazy that i can’t figure this out.

Hi guys, I have the same problem, I think that it depends on xbox1.6 version. I try different retroarch versions (0.9.8\1.0.2\1.7.1) and always got scrambled picture.

1 Like

I got to the RetroArch Github through the forums and opened an issue:

Hoping this gets somewhere.

how do i install retroarch on xbox1?! :S The link to the guide is broken

Having the same issue on my Xbox 1.6. I can confirm the Xbox model through XBMC info settings.

1 Like

I’m new to loading this on Xbox and was wondering how I would actually go about it I can’t find any information on on how to lead retroarch on an ogxbox really anywhere

It was simple for me. Just drag and drop the folder. The xbe was found by xbmc

Same problem, 1.6 here.

Twinaphex, can I send you (or RA developer) a 1.6 xbox? Are you in the US?

Any updates for this?