Retroarch 1.7.5 on Windows 10 MAME issues, Metal Slug


#1

Greetings,

I’m running Retroarch on a Surface Pro 4 and have been able run just about every emulator core that I’ve wanted to but when it comes to trying to load Metal Slug it kicks me right back to the main Retroarch screen. I’ve tried all of the ones with FBA and MAME in the title. Any ideas?

I have been able to get Metal Slug to work with Neorage x-1987 emulator by itself.


#2

Do you have the neogeo.zip from the same ROMset in the same directory as your Metal Slug ROM?


#3

I don’t. All I did was try all of the FBA and MAME cores listed in Retroarch. I’m new to this so any help would be greatly appreciated.

The cores listed in Retroarch for NES, SNES, N64, and all of the Sega systems have worked fine. This is the first time I haven’t been able to use a core listed in Retroarch.

Thanks.


#4

Ok, no worries. What I mentioned is what you need.

Arcade emulators are a little more complicated than console emulators insofar as they require specific ROMs that match the emulator and sometimes games need additional ROMs beyond the game itself.

This document will be helpful: https://docs.libretro.com/guides/arcade-getting-started/


#5

work with Neorage x-1987 emulator by itself.

You just answered your own problem there…


#6

Huge help, thanks for the info.