Retroarch and freesyc/gsync Stutters again


First all, thank you for this forum.

It seems that Vsync in RetroArch is mandatory if you want to use Gsync, as without it, the latter does not activate or work (source: [link]( … ync-users/)).

NVIDIA panel configuration.

If I don’t limit the FPS in RetroArch, for example, if I leave it at 141fps to play OpenLara at more than 120fps, it causes stuttering in 60fps games.

By limiting the FPS to 59.9 using MSI Afterburner, I manage to achieve a smooth experience, meaning perfect framerate without stuttering.

RetroArch configuration: Vsync on (mandatory to enable Gsync).

RivaTuner configuration.

In other words, if I limit it to 59.9, I fix most games, but it affects Dosbox Pure and OpenLara, where the former reaches 72fps and the latter reaches 1440fps. In OpenLara, it’s not as noticeable, but in Dosbox, it ruins pinball games.

I’m not sure if someone can help me, but I understood that VRR (gsync or freesync) precisely limits the frames to what the game requires, and I realize that if I leave the FPS unlimited at 59.9, it’s as if VRR (variable refresh rate) doesn’t work.

I’m having stuttering issues on Windows 10. My system specs are an AMD 5800X with 64GB of RAM, Nvidia 4070ti, and NVMe Gen4. The monitor is a Gigabyte that supports up to 270Hz with options for 120Hz, 165Hz, 200Hz, 240Hz, and 270Hz.

Currently, I have the monitor set at 165Hz. Using Custom Resolution Utility, I can force other refresh rate configurations, but the key is that RetroArch has issues when I don’t limit the FPS to 59.9. If I don’t use RivaTuner and let RetroArch detect up to 165Hz = 162fps (always limiting 3 or 4 fps for optimal Gsync), there seem to be problems.

The issue is that even with Gsync enabled, if a game has 60fps and I run RetroArch, it doesn’t seem to work properly. The GPU fluctuates a lot, and stuttering occurs.

Can you recommend any configurations?

What am I doing wrong?"

All of this is with a freshly formatted Windows 10, no background programs, everything optimized.

1 Like

don’t limit RetroArch’s framerate externally and don’t force vsync via any GPU control panels or external utilities, then go to RetroArch’s settings and make sure vsync is ON, sync to exact content framerate is ON and set the video_refresh rate to match the max refresh rate of your monitor (I think in your case it’s going to be 165 Hz, since that’s what your modeline is forcing; if that doesn’t work, try the true max). That should be it.

1 Like

thank you.

I will do your recomendations.

One question, what you refer about “try true max”.

270 Hz or whatever the max it is physically capable of.

Than you again and sorry for my poor english.

I have condigured my screeen refresh rate to 270hz, in retroarch i set the 270hz in options, i have disabled frame limit in riva turner, but the problem persist, is the same like in first post.

Im desesperated, i dont know what is the problem, i have set the recomended settings by libretro manual and tryed exclusive full screen and windowed screen.

Only frame graph its a disaster, unstable.

I tryed set 120hz vsync 2 for games run in 60fps, but the frame graph continues bad and i have a stutter.

Could anyboy help me? Later i will show you pics of my configuration, right now im formating again my pc for have a clean installation.

I believe @Tatsuya79 is the resident expert on these settings, so maybe they can chime in with some advice.

Thank you @hunterk,


These is my rig configuration



It’s “he” not “they”, I’m not multiple people, we’re going crazy nowadays. :upside_down_face:

You don’t need to enable any “frame delay” option in RA, it doesn’t work with gsync, it just uses cpu time for no benefit (I recorded the screen to test that a while back, same thing for “hard sync” when using gl = useless).

From RA default cfg you just need to:

  • set your monitor max refresh in settings>Video>Output>“vertical refresh rate”
  • activate settings>Video>Synchronization>“Sync to exact content framerate”
  • quit RA to get all that saved

The only settings I change in nvidia panel is to force GPU max perf (helps to keep low latency with complex shaders among other things), so idk if what you changed can cause issues.


lol damned if I do, damned if I don’t


@Tatsuya79 thank you again, i love your recomendations and experience about retroarch project.

Ok, it seems part of the problem was the nvidia control panel GPU energy it was in “normal” mode i have set it in “max performace”. Well the scroll seem to be more stable but i don´t know if frame time must be “plane or flat” (sorry for my english).

Right now, my question is about frame time graph, in Retroarch main menu is flat, but when play Shinobi 3 for example, the graph is not flat. This is normal? is ok?

The next screenshots is how i have the retroarch configuration.

Frame delay is disabled ¿thats is true gsync wont works with frame daley :frowning:?

pic image upload

I would see flat frametime graph but i don´t know if it must be flat.

Sorry sorry for this many questions, i love Retroarch a Libretro project i cant live without them.

1 Like

There’s just 1 frame of lag in that Shinobi game btw (for runahead).

I have disable desktop composition disabled, I think it was just for win7.

1 Like