Retroarch - android tv - xbox controller ( generic usb logitech chip )

I have been spending the last 4 rainy days trying to get Retroarch with Libreto Mame working without any Luck. I have tried installing 0.39B ROM - 2010 Roms and FBA roms all without any luck I have loaded the CORE once losed they cant be removed so I reset the box and reinstall everything again.

The controller works within the main menu but for some unknown reason does not work 100% all the time in consoles or after launching a rom. I have exhausted all the avenues I have but I can shed some light to help diagnose the problem. MAME4DROID works with a large number of 0.39B roms. SNES9X works with but controller delay is just crazy. they work outside of retroarch but not in the cores provided… I have run all database and asset updates and even the profile updates but still no luck :frowning:

What is the specific retroarch version you are running? What controller is it Xbox or logitech?

Have a look in Settings-Input-User 1 input binds and also the Hotkey section.

There is an Input guide in the Guides forum. Its for windows but the principles are the same. Check through that and let us know.

SYSTEM is Android 7.1.1 Retroarch Build - Feb 16 2018 Core Version 6fc6bfb

Port #0 Generic x Box 360 (#0) Port #0 Logitech F310 Port #0 Logitech_f310.cfg VIP/PID 3695/1025

Controller is actually a @play Xbox360 clone but is identified as Logitech by the Android

I have loaded CORES for NES - SNES - MAME - FBA - for testing I have the rROMS but they dont load they boot to blank screen or just flash and return to menu. !

Controller looks like it plays up and I constantly need to plug in until I get Port #8 to recover control when its freeses or joystick stops working. sorry if I mistype things here I just broike my glasses and I cant focus on screen :frowning: Thanks for your help

Very strange, your issue is beyond me ;( sorry about that hopefully someone else will pop in

Thanks Thatman for tring to resolve the problem… If anyone else can help please I would like to hear from you.

We can’t really tell much without a log (and sometimes not even then):