Retroarch build issues & release fragmentation woes!

Hey guys! I’m new to retroarch. It’s sheer size used to throw me off on Windows, but now that I’m mostly on Debian, I find it fits the bill :wink:

I have come across several issues that spurred several headaches and It would be appreciated to get some feedback!

Release fragmentation woes!

This one is quite simple, I see ArchLinux has v1.7.1 in it’s repos, Debian has v1.3.6 and Ubuntu, v1.4.1. What is keeping the Debian & Ubuntu guys from getting the latest updates? Is there somekind of package conflict between versions and distros? If this is purely due to retroarch being low in priority for Debian, I’ll gladly open a ticket with the devs to try and push 1.7.1 but I need some insight before I go all #retroactivist on them :smile:

RetroArch build issues!

Maybe someone could shed some light on this… Initially I installed RetroArch 1.3.6 from the Debian repositories and it had quite a few suspicious quirks. For example, “Load Core” would give me the possibility to download Cores (It would show downloading 100% then nothing would happen), but as soon as I installed some Cores from the Debian Repository that option went away, and I was stuck with the very limited set of Cores available in the repository.

RetroArch 1.3.6 had some strange behavioral differences also when running as root or user (Using root to try to find a solution to the Core problem). After several attemps, I failed to do anything constructive and so let’s skip ahead. (Games ran fine btw with the old cores from the repo.)

I tried to find an up to date version that I could easily install on Debian. Empty handed, I had no other choice but to build it myself. Now here is where it gets interesting…

I did a mistake with the first build, I ran it as root after getting the “build-dep”. Needless to say, most of the files were locked behind root priviledges. The application ran fine the first time aside from a big black square on the top right corner. After playing around in the menus it crashed, so I closed it. On the next launch though, it was completely frozen. FUBAR!

I cleaned everything and built again, this time as user, and now RetroArch simply wont run, the 2nd build it loaded the usual template, and each subsequent build loaded pixelart fonts. (Each build had large black squares and missing icons.)

Wow that’s a lot of text! Sorry XD

I hope I can get 1.7.1 running on Debian! If anyone has any insight or personal experiences to share it would be great! I really want to adapt to RetroArch as my daily driver :stuck_out_tongue:

If it’s of any use, I’m using Debian 9 sid with i7-7700HQ & GTX 1060 Max-Q, except the Nvidia card is not quite all set up yet. It’s installed but it’s not currently being used.

Thanks! :smiley:

Debian always has old packages for everything, AFAIK. I don’t think it has anything to do with being low priority.

In Ubuntu, you can use our semi-official PPAs. The ‘testing’ PPA has nightly builds while the ‘stable’ repo only has the stable releases. Ubuntu also has our snap package, which works pretty well, in the official Ubuntu Software Center.

Some of the discrepancy you’re seeing between self-compiled and distro packages has to do with how you get cores. If you install from a distro package, we typically hide the core downloader, since we assume you’ll be getting cores from the package manager, as well, and your core directory will be outside of your user-writeable path (hence having to use root to download cores, which is not recommended). You can still go to settings > directory and change your core directory to somewhere user-writeable (such as ~/.config/retroarch/cores/) if you want to use the core downloader with a distro package of RetroArch. If the core downloader is hidden, you can unhide it (on relatively recent releases) in settings > user interface > views.

The block font and black squares indicate that you don’t have (or RetroArch can’t find) the needed assets, which include fancy icons and fonts. I think some distros provide those as a separate package, but if not (or if you compile yourself), go to settings > directory and set your assets directory to somewhere user-writeable (such as ~/.config/retroarch/assets/) and then go to the online updater and ‘update assets’.

1 Like

Woot! Thanks for the detailed response! :smiley:

Hmm seems there’s some text formatting tricks I was not aware of! None of that text was supposed to be bold XD

I’ll be working on retroarch again tomorrow. With the things you mentioned it should help me get started now that I’m a bit more informed! I’ll report back if there’s anything!