RetroArch: Corrupted Interface in Linux Mint 19


#1

Hey folks! I just set up Linux Mint 19 on my PC and I installed Retroarch from its PPA. When I open it, I’m greeted by this:

Any idea why this is happening? What can I do?


#2

You seem to be missing the assets package. Either install that or go to settings > directory and change the assets directory to somewhere user-writeable (somewhere in ~/.config/retroarch is a good place) and then go to the online updater and ‘update assets’.


#3

Thanks so much, hunterk! Your response didn’t immediately solve the problem, but it set me on the right track.

The retroarch-assets package was already installed, and the Directory was already set to ~/.config/retroarch/assets, but that directory was empty. The Online Updater doesn’t have an “update assets” option, at least I didn’t have it on my system (is there another option I must set to unlock it?).

Anyway, I searched my whole file system and eventually found an “assets” folder in /usr/share/libretro, and when I pointed the Directory setting for assets to that folder, it started working.

Curious that I had to do this by hand. I’ve installed RA on other computers before (or previously on my own computers), in both Linux Mint and Ubuntu, and this is the first time this issue occurred.


#4

You probably had an old retroarch config in your ~/.config/, by default it’s set to /usr/share/libretro


#5

Yeah, it could be. I think I took a .cfg from my laptop, not sure right now. Thanks either way, guys! I appreciate that there’s always somebody here in this forum to quickly help out.


#6

I am having this same problem. I am a new user so not sure how to “point the Directory setting for assets to that folder” can some give me a bit more detail on this? Thanks


#7

In the retroarch menu, go to settings > directory. You’ll see a long list of things on the left and their assigned paths on the right. Go down to the one that says “assets” on the left and then hit the ‘accept’ button on it to bring up a file browser where you can navigate to the desired directory. Once there, look for the “use this directory” entry and hit ‘accept’ on it. Once you have it selected, go back to the main menu and “quit retroarch” and then relaunch. If you don’t see the black boxes filled in, go down to the online updater and ‘update assets’, quit retroarch again and relaunch.


#8

Thanks, I will give that a try when I get home tonight. One other question, on two systems I have both linux mint there is no “update assets” option in the online updater section. Any ideas on what is causing this? Thanks


#9

Yeah, the PPA package hides it because you’re expected to use the assets package. Just make sure you have that assets package and point the directory to the proper location and you should be good.


#10

Just to add to hunterk’s response, the exact package you need to install is called, “retroarch-assets”. If you have it installed, then you’re likely to find the proper assets in /usr/share/libretro.


#11

I found the root of this issue:


#12

so i have the black bars but also I have a problem that nothing responds. I can move the mouse but non of the buttons work not even escape to close the program. I had everything installed using terminal. the last thing i did was update libreto and it changes the look of the interface but then i got this problem. Any ideas for me? Thanks in advanced.