RetroArch crash at startup, no error message

Hi.

As the topic states, Retroarch crashed on startup, no error message, just quit.

It’s a new computer with (afaik) all drivers updated etc and no bloat to speak of.

I tried both nightlys and stable, same problem.

Any suggestions?

Try the command line procedure below the “tip” field on this page:

This should give us a log that will hopefully point us in the right direction.

It seem I had some kind of driver corruption after all. A fresh install of the GPU drivers seem to have solved it completely! :slight_smile:

1 Like

I’ll piggy back off of this topic since I am too new a forum member to start a new post yet.

I have a somewhat similar problem. I have been running RetroArch on my old PC using Windows Vista (yeah I know!) without issue for some time. However, I decided to upgrade this PC to Windows 10 to keep up with the times, so that I could use RetroArch with Launch Box. I upgrading the PC OS to 10 with no issue, did not change or add any software other than running all the system updates and then downloaded a Windows 10 version of RetroArch. However, when I open this new version of RetroArch it loads to a white screen with the only text being the top headings of File, Command and Window. No error message, its just stuck on the white screen. Seems strange that I had no issue with the old Vista OS, but somehow updating everything without changing the hardware would cause some type of loading issue to occur. Is their anything I can do to get this running normally again?

Are you using Intel integrated graphics, by chance? Intel doesn’t provide proper OpenGL drivers for its older integrated graphics chipsets in Win10 (they stopped with Win8.1), so it falls back to the “GDI” driver, which is a piece of crap (basically software-rendered).

You can try setting your video driver to d3d11, d3d10 or d3d9 (in order from best to worst) and see if that treats you any better. Cores that require GL, like mupen64plus, won’t work with it, but most cores will be fine.

The easiest way to change those settings is to open your retroarch.cfg in a text editor (make sure RetroArch is closed before you do this) and look for “video_driver”. Change it from the default “gl” to one of those options. Save, open RetroArch and see how it looks.

Thanks alot hunterk. I went through the process and got to d3d9 before it load correctly. I’ll take it even though as you eluded too its not optimal.

I’m glad that got you fixed up. Just FYI: you’ll need to use Cg shaders with that driver (if you care about shaders).