Retroarch crashing on startup. Works after restart

Totally confused with this. My Retroarch keep crashing. There doesn’t appear to be any rhyme or reason for it. Attempt to load it, black screen and then a not responding. Restart, still not working (although sometimes it works again) or a second restart and then it works perfectly again, no issues at all.

So what the heck is wrong here? Why is it just not working on some boot ups and then working again on others. This is a new system, but I do remember having this issue on my previous PC as well.

Windows 11, i5 13600K, 32GB RAM and an RTX 3080.

Totally confused.

We would need to see a log to even guess what’s going wrong, I’m afraid.


Thanks for replying. The error reports I found were:

Event Viewer:

The program retroarch.exe version stopped interacting with Windows and was closed. To see if more information about the problem is available, check the problem history in the Security and Maintenance control panel.

Windows Security and Maintenance:

A problem caused this program to stop interacting with Windows. Faulting Application Path: C:\RetroArch-Win64\retroarch.exe

Problem signature Problem Event Name: AppHangB1 Application Name: retroarch.exe Application Version: Application Timestamp: 00000000 Hang Signature: 42c9 Hang Type: 134217728 OS Version: 10.0.22621. Locale ID: 2057 Additional Hang Signature 1: 42c9cb41d0ddc5d98840f8ee5d515fc6 Additional Hang Signature 2: f9f3 Additional Hang Signature 3: f9f3b1c2662359f9e371e22030941f72 Additional Hang Signature 4: 42c9 Additional Hang Signature 5: 42c9cb41d0ddc5d98840f8ee5d515fc6 Additional Hang Signature 6: f9f3 Additional Hang Signature 7: f9f3b1c2662359f9e371e22030941f72

I also have another Retroarch installed on my PC D:\ drive and this will crash with pretty much the same as the C:\ drive one.

Of course, when it works, both versions work. Very strange indeed :thinking:

We need to see a log from RetroArch:

there are a few ways to get a log, but the easiest is to go to settings > log and set both logging verbosities to DEBUG and ‘log to file’ to ON. Do whatever it takes to reproduce the offending behavior and then close RetroArch (if needed). It will then create a log file in your ‘log’ directory, which you can open in a text editor. If you want us to take a look at it, copy/paste the log contents somewhere like and then post a link to it here (this is more convenient for people than having to download it and open it in our own text editors)

Hi there. I really appreciate your help here. thanks.

I’ve created a log. You can view it here:

Just to add, I’ve got two displays, but only one is enabled at a time. Does RetroArch have issues with two displays?

multiple displays complicate things, but it doesn’t really have issues with it, no.

Hmm, not much going on in that log. Does that include a crash?

It was crashing at the time. Other tests had it hang for about 60 seconds, then finally launch. But closing and opening again had it hang again.

I’ve some theory’s of my own. Need to test them out…

Do you have a Corsair keyboard, by chance? If so, does it resolve itself when you unplug it?

Ah, i do have a cosair. I will test it later.

Yep, it’s the Corsair keyboard. Unplug it, works, plug it in, crashes. Is there a fix, other than a new keyboard lol?

1 Like

An update.

iCue software might have been the culprit. Not 100% sure yet. However, being doing some typical usage tests again after removing the iCue software and now it doesn’t seem to be crashing anymore. Retroarch has been working after a usual PC shutdown.

No big loss, wasn’t using the iCue software anyway. I thought I’d disabled it from launching some time ago, but noticed that it was still loading some bits when looking through task manager.

Hopefully fixed now. If so, hurrah!

Thanks. Would never have thought the keyboard (or software) would have been the cause.

Nope, spoke to soon, it’s crashing again, and this was before a restart, just stopped working. :unamused:

Did you try a Fresh Install/Unzip?

I’ve changed the Keyboard to a CoolerMaster. Not sure if this has fixed it, but it seems to be working again now.