Retroarch + CRT : problem on a particular game + refresh rate question


I’m using Retroarch 1.7.7 on a CRT, with CRTemudriver on windows 7. There’s something weird happening with Sonic 2 for the master system (I’m using the Genesis Plus GX core) : whenever I run it, I’m getting a 50 hz interlaced resolution. With my other SMS games I’m getting the proper resolution.

Also, after running Sonic 2, the value of the “video_refresh_rate” line in the retroarch.cfg file is changed from 60 to 50, and I have to manually correct it. What could be causing this problem ?

I also have another question :

To get proper sound and video sync I use the estimated refresh rate value and set it like it should be, after the 2048 samples have been calculated. But the changes are never saved when I run another game or close Retroarch, and the value gets reset to the default 60.0000000. Is this normal behaviour ?

Thanks !

The obvious question: maybe it’s the PAL (European) version of the game? That would of course result in 50Hz.

1 Like

It’s the “Europe, Brazil” version that I’m using, for some reason I can’t find the USA and Japan versions. I tried to find a way to force 60 hz (most emulators seem to do that automatically unless instructed not to) but don’t know how to do that.

It wasn’t release in the USA. A lot of SMS games are PAL only and are meant to be run at 50hz, if you run them at 60hz they’re too fast (especially sonic 2, ninja gaiden, power strike 2 etc). You’ll need to have a 50hz modeline set up with VMMaker. For retroarch on a CRT I just use 2560x240 @50hz and set up the borders in the genesis plus gx core settings so the vertical aspect is correct with Master System games.

PAL-M (Brazil) is 60Hz from what I understand, not 50.

Since the native resolution of the system is 256x192, I added a 2560x192 @50 hz modeline in vmmaker, but I got the same result.

Ok, I’ve found out what was wrong : I had to change the mode table method in vmmaker from dynamic to static, since Retroarch can’t manage dynamic tables currently. Now I get the proper 50 hz resolutions, with the borders. I could get rid of them by forcing NTSC ratio but that gave me an ugly interlaced resolution.

1 Like