Retroarch display looks like old MS-Dos

Hi team!

I’ve been troubleshooting for days and still can’t get this to work. Retroarch used to work fine, but then i upgraded and I’m having a world of trouble. First it wouldn’t open. Then i added a line to the cfg to make my video driver d3d9. It opened to a b lack screen, Then i switched menu driver to rgui. Now it opens but the display looks like something from MS-Dos. Block letter and very large pixels.

I tried nightly builds and downloading previous stable versions with the same results. I’m running Windows 10 64-bit with a Radeon RX Vega M GH integrated graphics card.

Help please!

Rgui looks like that.

Have you tried gl ? What is your GPU ? Are your drivers up to date ?

Thanks for the response. I wasn’t aware of what rgui actually did. I was just trying things I read on the forum so that makes sense then.

I’ve tried gl with both rgui and xmb. In both cases, it doesn’t start. My GPU is a Radeon RX Vega M GH.

Yes, my drivers are up to date.

Try DX it seems your graphics card isn’t compatible with GL.

That’s the reason it only shows rgui.

I input dx for the video driver with both rgui and xmb and it does not open.

With the config that doesn’t start, launch “RetroArch (log to file)” from the Start menu or retroarch_debug.exe from RA’s folder and post the contents of retroarch-log.txt to and give us the link.

If you’re modifying the config, “dx” isn’t an option, but “d3d11”, “d3d12”, “d3d10” and “d3d9” (in order of preference) are.

d3d10 did it! You guys are all amazing. If you don’t mind me asking, what made that particular driver work?

It depends on what your GPU supports. I would expect Vega to support dx12 and/or 11, but if it only likes 10… well, that’s okay, too.