RetroArch - gamegenie and actionreplay cheats not working

Besides being outstanding, one small but powerful function caught my eye. Yes people, I have tried to activate cheats on so many genesis and snes games. Besides knowing some are fake or not working, I also tried ones I know are legit. None of those worked for me.

What I tried: - I tried redownloading cheats - I tried loading them with game - I tried restarting the game with cheats on - I tried reenabling them - I tried toggling and then applying cheats - I tried toggle+apply at same time - I checked rom version which were exact with cheats file

Nothing above worked for me. Does anyone know whats the deal here? What else can I try?

P.S. Please be kind and do not respond with hatred. If you do not like or want or do not cheat, please do not offend others. Any little sarcasm in replies will be reported.

Well, I tried four games and they worked right away:

Chester Cheetah - Too Cool to Fool (USA).md	(Genesis Plus GX)
Chester Cheetah - Wild Wild Quest (USA).md	(Genesis Plus GX)
Chester Cheetah - Too Cool to Fool (USA).sfc	(Snes9x)
Chester Cheetah - Wild Wild Quest (USA).sfc	(Snes9x

I suggest next options:

  • Try a different core. Not all of them support cheats. You can always search the docs for core’s information, there you’ll find if it has cheat support or not.
  • Try a different cheat (download it elsewhere, ask someone for them, or make you own).
  • Try RetroArch’s cheat code searching, read the docs.

I hope it helped (˳˘ ɜ˘) ♬♪♫