Retroarch keeps crashing on Pixel 6 Android 13

Hey, first post here.

I couldn’t find anyone reporting the same problem on the forum, Twitter, Reddit nor on the Discord server. I tried installing both the Retroarch and Retroarch Plus apps on my Android device (Pixel 6, android 13) and the thing just keeps crashing the second I switch apps/turn my screen off. I did try several different Retroarch APKs, including both of those that are on the Play Store, a Nightly build, the one on the Retroarch website and an older stable build. I also turned battery optimization off for each one of them but that’s the only setting I figured could be causing the problem. I’ll also clarify that these are all clean installs (other than the first one, where I found out about the issue after I already set up a bunch of stuff) (edited)

I tried turning the logging option on and saved my config but it won’t generate any log file on crush.

Wondering if anyone here could possibly have an idea what’s causing this problem.

1 Like

I’ve got the same issue on pixel 6a with Android 13


You should try to provide some log.

Thank you.