Retroarch Mame problems

I just installed retroarch and I have 2 problems with mame. The first is that the “~” key which toggles the On-Screen Display doesn’ t work. The second is that when trying to exit from a game, then the mame menu appears and cannot exit mame from there(cannot select the exit option), so it forces me to exit retroarch. I have disable the press esc twice to exit option and also I changed the esc key to exit retroarch.

1 Like

Maybe you need to disable hotkeys when mame is operating. I think its the scroll lock key.

Doesn’t have any effect. Still the “~” doesn’t work and cannot exit mame menu.

1 Like

Two things.

  1. The “~” key doesn’t call up the UI the “Tab” key does.

  2. Once you are in there you can customize the “UI Cancel” key

Input General>User Interface

and change it from Esc to something else. I use Backslash. (The default Esc is an issue because it and RA both use it to exit.

For “~” key, I found this definition in mame docs. This key displays a volume bar on mame. I already tried to change the “Ui Cancel”, and also to change retroarch exit hotkey to another one. This didn’t work too. The problem isn’t that the keys don’t work. The problem is that instead of exit mame open the mame menu and this mame menu(inside retroarch) not working as it should. If I open just mame itself this menu is fully working and I can navigate there either with mouse or keyboard.

1 Like

It sounds like you don’t want the hotkeys interrupting while you use your keyboard, in that case try “Auto Enable Game Focus Mode” which can be found in your settings menu --> Input

In My Experience when I was playing MS-DOS games, the hot keys were activating during gameplay and this suggestion to enable game focus mode helped with preventing that when Im using a core.

You could also assign a different hotkey which brings up the quick menu so you can close the content/Restart/ etc.

P.S. Just to be clear, Are you trying to play MAME wiht a Keyboard? If you need a recommendation for a controller I recommend the Logitech F310, it’s sturdy, reliable, has X-input/D-input and works right out the box for PC Gaming and most platforms. It was also cheap at $14.99 on Amazon. It does have a hotkey center button right in the middle of the controller.

In RetroArch (Ozone UI)

What MAME core are you using? I haven’t had any problems doing as I described with the MAME (Current) core. This is a well documented solution.

I tried with three different cores(current, mame2000, and mame2003+plus) and it didn’t make any difference. Same problems in all.

@Joystick2600 I tried with “Auto Enable Game Focus Mode”, and didn’t solve anything either. Yes I use keyboard and I don’t want to use a controller, I prefer keyboard. I have an old controller though but I haven’t tested.

1 Like

The game focus is important if you are using the keyboard to control the game. Not important for the MAME UI.

As I said. The conflict between both MAME and Retroarch using the ESC key to exit is well known. The solution is to change the UI Cancel hotkey in MAME. Make sure you are choosing a key that isn’t already used for something else. You should be able to use it to back out of the menu after setting it.

At this point, since you have been trying a lot of solutions, it may be beneficial to try it on a temp fresh install of RA to make sure there are no config conflicts.

As I said I’ve done that. My problem isn’t to exit game and not exit retroarch as well.The problem is that cannot quit mame. I already have change the Ui_Cancel key to “Q”, and I can quit the game and not retroarch(which exits with esc key). But instead to exit mame as well this action exits to mame’s ui and there cannot do anything except to select another game. Pressing the “Q” key doesn’t do nothing, mouse clicks not working also.

EDIT: Just tried some other keys with same result. About mame Ui which appear on exit, somehow has enabled the search action and whatever key I press it writes weird characters to this search area. Only with enter can start the selected game, but again when exit that game the mame ui appears again with the same problem. Tried to run retroarch with a different window manager(I’m using Plasma) in case this is related to Plasma, but I had exactly the same problems with blackbox which I tried.

1 Like

I see. So you are using Retroarch as your front end and you want to quit back to the Retroarch UI? Do you have MAME Core options set to “Boot to UI”?

I haven’t found this option, but I found how to close game without close retroarch or trigger mame’ s ui. I found that there is an option to close content in Input -> hotkeys and using this I can exit a game. So, I assign this to “esc” key and also enable the option to confirm retroarch exit. With this I can use escape to close game, which i prefer without to close retroarch. This seems to work fine without conflicts.

1 Like

Very nice. I wasn’t positive there was a Close Content hotkey. I’ll have to make note of this. I am tired of Android front ends and am planning on using RA UI instead.

I’m nor sure if i understand the problem.

With a fresh RetroArch install and mame (current), mame2003, mame2003-plus, FBNeo… you press [F1] in-game for bringing up the RA UI.
There you can “close content”

For the mame menu (config menu) you press the [TAB] key and you exit the mame menu with the [TAB] key again. Default the [ESC] key opens the mame UI. This can be changed in the mame menu. Alternatively you can change the “Exit RetroArch” hotkey in the RA settings - input

And yes, the mame UI isn’t working in RetroArch