RetroArch - Native CRT Support


#302

Sure thing. I don’t think anyone has started yet, but I’ll bring it up just in case.


#303

Yes the whole point is to get games which originally ran on CRTs to run in retroarch as originally intended. Handhelds ran on LCDs with much lower resolutions so there will always be a trade off.

I’m pretty sure any official adapter for handheld games to run on a CRT added borders to get round this which is basically what we are doing here.


#304

Thanks @Alphanu! Turning integer scaling on solved it completely :smiley:

What Radeon card is good enough to run 480i? Any card from the 5xxx? And what would be the benefit of getting say a 79xx card or similar - the ability to apply more shaders? Something else?

On another note, I got N64 running through Parallell working much better. I had to disable V-sync and Hard GPU-sync and now the stutters are gone. Thought I’d share this if someone else experiences similar issues. However, I cannot get the VI overlay filter working. All I get is a black screen. I can still hear the sound of the game though. This is probably not the right place to ask, but if anyone has gotten Parallell Angrylion+VI Filter working with CRTSwitchRes I would really like to know how. For now I use the Advanced AA-shader and think it looks pretty authentic, but I would prefer the VI filter obviously.


#305

Is there a way to have the RetroArch menu displayed in 240p instead of the current interlaced one? My screen just flickers like crazy.


#306

No, there is not. However, this is only set for menu only. The menu will scale with the current game loaded so if you are running snes and press F1 the menu will be in 240p.

Its been designed to give the maximum possible size for CRT in menu only so you can see more when choosing cores games and settings.


#307

If we’re expecting them to use RGUI for the menu instead of XMB anyway, it should look the same at 480/240


#308

OK, cool. Well it would be a simple toggle like CRT switch to engage 240p menu! I can add this when I get back to working on this, in a few weeks.


#309

OK, as @hunterk has enlightened me into the fact rgui should scale and show everything similar to 480i in 240p. I have made this quick change to my fork. As there are many other changes not ready to merge with RA you’ll need to download and compile my source.

@DatMonkey


#310

Thank you, looking forward to it! Almost everything I play is progressive so keeping everything looking the same will be nice :slight_smile:


#311

What’s a normal ETA until a change like this appears in a regular Retroarch nightly? Github is a bit over my abilities.


#312

I’ve created a pull request for this and an aspect ratio fix for Linux. Once merged I will let you know.

It has been merged. So it will be in tonight’s nightly.


#313

Hi,

I get this error on ubuntu 18.04 and both are installed. sh: 1: xrandr: not found sh: 1: xdotool: not found

Any suggestion is wellcomed.


#314

with Ubuntu you’ll need to install xdotool using “sudo apt-get install xdotool” I’m not sure why you are seening xrandr not found, I am sure ubuntu 18 uses xrandr!? I’ll look into that one and get back to you.

Are you sure it does not say xrandr output not found? or similar


#315

Thanks Alphanu, I have xdotool and xrandr installed and retroarch says sh: 1: xrandr: not found sh: 1: xdotool: not found


#316

That’s a strange one. I assume when your in terminal and run xrandr it works ok?

Have you tried running RA in super user mode?


#317

yes xrandr works

When I try to run retroarch with sudo it does not start.

I think that retroarch 1.7.3 is not tested with the latest version of ubntu. It also does not detect the usb joistick.


#318

Are you using the snap package, by chance? I doubt it’s going to work with res-switching due to snappy’s funky sandboxing stuff.


#319

Thank you very much Hunterk,

Yes I am using the snap version, I will try the ppa version. What distro of linux you use?


#320

I use Ubuntu and do most of the work on the snap package, which led me to suspect that’s what was going on.


#321

Thank you very much again Hunterk,

With the ppa repository everything is fine in ubuntu 18.14. For the moment, I just tried the core of bsnes with the version of Supermario World ntsc. In the upper part of the tv there are some black lines.

Is there any way to vertically center the modeline without touching the TV settings using modeline generated in your code?

Can it be by touching a configuration file?