RetroArch No Input at Startup [Linux Mint 19]


#1

Greetings community!

I’m running Linux Mint 19 Cinnamon and I installed (the 1st time) RetroArch by Terminal. It worked fine for quite some time, although I don’t remember exactly what version was installed, but after a while I used ‘Update Manager’ and I believe it updated my RetroArch too.

Now my RetroArch always boots up in Fullscreen mode and no input works whatsoever. I always have to terminate its process.

I’ve tried uninstalling and installing it through ‘Software Manager’. Running BleachBit between each installation attempt. I’ve tried deleting every ‘retroarch.cfg’ I could find but to no avail. When it boots up it doesn’t freeze, but no input absolutely works! I’ve also tried changing input from udev to linuxraw but that also didn’t work :frowning:

Anyone have any idea how to help me? :frowning:

Thanks in advance!

p.s.: I’m a total noob that just moved away from Windows for the first time!


#2

Try a different input driver?


#3

No go :frowning: One thing I noticed is that for example I tried changing ‘retroarch.cfg’ (in /etc) fullscreen options to false and my RetroArch always starts fullscreen no matter what … So maybe the file’s not being read at all?


#4

Correct. That’s not the one to modify. That’s one’s just a reference. Instead, modify the one in ~/.config/retroarch/retroarch.cfg or, if you’re using the snap package, ~/snap/retroarch/current/.config/retroarch/retroarch.cfg


#5

I tried searching my File System drive for it but I can’t find any path that starts with either .config/ or /snap.

Instead the only folders showing are in /usr but none have ‘config’ anywhere. And the only one exists solely in /etc

Oh boy … :frowning:


#6

In linux/unix, files/directories that start with ‘.’ are hidden and won’t be visible in the normal file browser. Applications typically store their user files and preferences in ~/.config/[application-name] (that’s /home/[username]/.config/[application-name])


#7

Thank you!! Changing it to ‘linuxraw’ solved the issue there! … However now for some reason I don’t have any Cores available … I use the in-app feature to download cores, but … None of them show up. :confused:


#8

Perhaps your ‘libretro’ directory has gotten changed? If you’re getting them from the online updater, that location needs to be either ~/.config/retroarch/cores or ~/snap/retroarch/current/.config/retroarch/cores.


#9

Thank you once again :slight_smile: However one problem breeds another, and being a newbie at all this doesn’t help, I’m sorry for that…

Anyhow … I fiddled around at first with that and I actually got those cores to show up and… Sorta work. Until I tried to start a game and it told me it failed to load the libretro core.

But seeing as I wanted a fresh start I deleted the retroarch folder found in .config, deleted all other files related to it and ran BleachBit.

Now I ran this piece of code “sudo add-apt-repository ppa:libretro/stable && sudo apt-get update && sudo apt-get install retroarch libretro-*” from the main page thinking it’d give me full and easy no hassle instalation.

… But my RetroArch lost the Core Updater function and when I try to direct the Directory towards the Core folder found in .config, it doesn’t show me “.config” and other folders under “home”.

Been at this all day and I feel like I understand less and less :frowning:


#10

Part of the confusion is because you’re mixing and matching stuff. The intention is that you do one installation method, not a little of this one and then a little of that one :stuck_out_tongue:

The PPA installation method assumes you’ll be using the package manager for cores, instead of the online updater. That means it expects the cores to be stored somewhere else (I think it’s something like /usr/lib/[arch]/libretro…?). You can still use the core updater, but you’ll need to change the libretro directory back to ~/.config/retroarch/cores and go into settings > user interface > views and make the core updater visible.


#11

Oh ! So … Hmmm … I should pick one installation method like say … Either install the whole thing through code (by the Terminal, which is the PPA method?) or by ‘Software Manager’ which is uh… Well… Like a .deb installer, or something, right ?:sweat_smile:

I hope I’m at least removing excess files and folders right… So far I only know about the files “spawning” in usr and the ones in .config, like you taught me. :slight_smile: I removed everything once again and trying to do a clean slate start.

And you were right, because most of the time the cores were pin-pointed there!

Right now I guess I’ll just try to install through the Software Manager and see how it goes from there. :sweat_smile:

Edit: So a small update: I installed it all through ‘Software Manager’. RetroArch loads up fine and what not and I head forth towards enabling the Core Updater option to show up. I do so and I remember I have to change the directory first, so I head there, and when I try to go home>User>.config … ‘.config’ or any other hidden folder simply doesn’t show up.

I try to counter this by going to the cfg and editing the path manually. Except this arose another problem. Now when I click the Core Updater option it gives me “Task Failed. Downloading Index”…

Edit #2: After doing absolutely nothing the Core Updater function works but… It gives me an incomplete list of Cores to download (and all I really want is just a GBA one …)

Edit #3: Now it shows me the full list again and I’m able to ‘download’ VBAM but … I can’t change in-app the Directory because the folder doesn’t show up :neutral_face:


#12

you don’t have to keep your cores in the hidden folder. You can change it to wherever you want. Like, you could make one in your user folder instead.


#13

Following that suggestion I was able to change the folder for the cores themselves, not only that I found out where the “see all files and folders” button was.

However !! ( :sweat_smile: ) … Whenever I scan my folder with GBA games it scans them so quickly, but nothing happens afterwards… Only way I’ve been able to play them was by loading the Core> Load Content> Start Directory> “gba games folder”> game.zip> Load Archive> VBA-M.

Not that I mind but… I’d like a list like I’d seen in screenshots. Also for some reason my RetroArch has no icon :frowning:

These are truly minor things, of course, but if you could help further I’d be super glad! Thanks a ton Hunterk!


#14

I don’t think you can scan ROMs inside of archives. Also, they need to match our databases (based on No-Intro).

Not sure why the icon would be missing, but you can check the launcher in /usr/share/applications/retroarch.desktop (or something like that) and see where it’s looking (probably in /usr/share/pixmaps) and then make sure there’s something there. If not, add it.


#15

Thank you :slight_smile: I was able to fiddle through the Launcher>Edit and locate an icon (inside /pixmaps)

As for the ROM scanning … I mention that because before I started down this confusing path I had it setup like that. It’d have a GBA icon and every game in that category would have boxarts next to it and everything!


#16

Im trying to follow this thread as a guide for my same issue, What exactly did you change to ‘linuxraw’? I am looking at the retroarch.cfg file but im not sure what to change. I am Very new at this.

Also What im trying to fix is that the menu doesn’t respond to any comands that I input from the keyboard. So I can’t look around to see it i have any cores or not, it’s just completely unresponsive. I see on the retroarch.cfg that the all_users_control_menu was set to false, should I change that to true?

any help will be appreciated