Retroarch on new M1 MacBooks - controller issues!


So I’m familiar with retroarch on pi, windows and linux but not Mac OS and I’m trying to get it working on my new m1 MacBook Air. seems to be working fine except I can’t find a single joypad/controller that works! The closest I’ve come is plugging in a PS3 controller is actually detected in retroarch but says “not configured” when I plug it in. When I’ve searched for help on this the retroarch support says go to “user 1 bindings” and work through each option… However, I can’t find “user 1 bindings” in the menu! If I go to “port 1 controls” I can see it has detected “PLAYSTATION®3 Controller (1)”; however if I try to bind any of the buttons it times out as nothing on the controller seems to be detected.

Can anyone help me get ANY controller working on my Mac? I have xbox controllers and ps3 controllers and I don’t mind using a wire. Like I said it does actually detect the ps3 controller when I plug it in and knows when I’ve unplugged it too but I can’t get retroarch to detect any button pressed and can’t find this mysterious “user 1 bindings” in the input menus.

I would really appreciate any help as I’d really love to play my retro games on here with a controller.

Thanks, Lee.

I’m having the same problem with an M1 MacBook Pro and a Switch Pro Controller. I tried the common workaround of adding RetroArch to Steam as a non-Steam game and launching it through there, but that doesn’t work either. Steam is able to recognize my controller and respond to inputs like it should, but that doesn’t pass through to RetroArch once I launch it.

My M1 is on the way, but I can play with my Intel MacBook with no problem, wireless with 8bitdo controllers or DualShocks. Unfortunately, controllers on Retroarch macos seems to not use autoconfig, so you have to config by hand. You have to go to controllers and bind every button/crosspad/stick

I’ve actually never had any problems with my old Intel MacBook Pro (mid-2012) and my Switch Pro Controller. Retroarch recognizes it and does the mapping correctly for me. It’s just the new computer that has issues. When your M1 arrives, if you could try your controllers out and see if they work, that might be useful data. (Particularly if it works for you, because then we could try to figure out what the difference is)

Still need to try this one:

Using a PS4 controller in Silicon without issues, so I‘ve been lazy with this software

Sorry for being late. I have no problems with any controller on M1 macbook air. Dualshock4 and a pair o 8bitdos. All of them work fine (but I have to manually setup, autoconfig never worked even on intel)

Hey, new user here. I set up retroarch on my m1 MBA last night and it was working great, but today the controller support is borked. I’m using a switch pro controller. Last night the blue ring was on, now it is not. If I disconnect from bluetooth and reconnect, retroarch detects it as a switch pro controller, applies the config file, and assigns it to a new port, but still doesn’t detect input. Very strange behavior. Any help is appreciated.

I have a Sony PS1 Controller and use a PS1 to USB adapter to plug into my Macbook Pro. Retroarch recognizes the controller because, when I plug it in, it shows up under “Device Index” as "PLAYSTATION®3 and, when I unplug it, it says that “PLAYSTATION®3 disconnected from Port 1.” However, I am unable to use the controller at all; it times out when I try to map the keys. I’m not even able to navigate the menus. I’ve looked all over and can’t find a solution. Everything has been updated but, in the “Controller” section of “Drivers,” I only see “mfi” and “hid.” Is that all? Shouldn’t there be other options? Thanks in advance for any suggestions/help!

I am on macOS Sonoma version 14.3 with an Apple M2 Max.

My gamecube controller works with Dolphin but not Retroarch. Retroarch notices when I plug in the adapter but is totally unresponsive to buttons and joysticks being pressed.

Would appreciate any tips

1 Like

EDIT: To my amazement, changing the Settings > Drivers > Controllers to hid and then remapping my controls again manually worked!

1 Like

Just wanted to let you know that you’re a lifesaver! Been scouring the whole internet for hours trying to find the solution to my problem but nobody had the same issue and or a solution, so thanks!