Retroarch on Windows 10 starting and loading games slowly


#21

I JUST FOUND THE CAUSE, I feel important now, lol… It has to do with your controller, in my case I have a Wired Xbox 360 controller and it has a problem with the cables (I need to solder the cables) and it unplugged itself yesterday while I was gaming and went to player 2 (btw, Windows can’t fucking reassign your controller to player 1 sometimes, who knows why but whatever) but I didn’t launch Retroarch until today to check something and I noticed the problem came back, tried reinstalling Nvidia Drivers to see if that could fix it again but nothing, then I started going through what happened in the last days and there was nothing new except for the fact that my controller got unplugged so I unplugged it again and launched Driver Booster because it has an utility to clean data from unplugged devices so I cleaned everything WITH THE CONTROLLER UNPLUGGED (I tried with the controller plugged in but it failed to fix it that way, it has to be unplugged) and then restarted, again, with the controller still unplugged and launched Retroarch and boom, fixed, Retroarch launches perfectly and instantly, then I reconnected my controller and now it works fine, no delays, so yeah, I’m pretty sure at this point THAT is the problem, I hope this works for someone googling this problem! :smiley:


#22

Amazing! Thank you for reporting. I have a K70 myself! Just for those searching for a solution, I switched my input driver from dinput to raw and that has fixed the issue for me. :smiley: