Retroarch on Windows 10 starting and loading games slowly


#1

Basically, when I start up Retroarch, the icon will show up in my taskbar and my mouse cursor disappears as if it was actually starting. It stays like this though, and if I click, the screen goes black and I get the blue loading cursor.

Eventually, after a while, retroarch will start up. If I go to select a game, the same thing happens, and the game will eventually start. I can still “use” Retroarch, but everything takes much longer to do than it should now. The version I’m on is 1.6.9, but I’ve tried the latest one and older versions (as far back as 1.3) and the same thing happens. I’ve tried switching out menu styles, switching to different video drivers, but nothing seems to fix it. Sometimes Retroarch will work normally If I’ve just started my PC, but it’ll eventually start having the issue. If it matters at all, here are my PC specs: Windows 10 Pro, i5-6500, Nvidia Geforce GTX1060 6gb, 8gb DDR4 RAM

If it would help, I’ve also taken a quick video of the issue to better show what exactly is going on and how much longer it takes to start up and load a game. https://www.dropbox.com/s/vopk4p5dibzvvm3/20180812_184135.mp4?dl=0

Edit: I generated a log to see if it might help. If anyone could try to make sense of this for me, that’d be great: https://pastebin.com/deZ6DmZC


#2

Nothing specific from the log jumps out at me.

Try moving your retroarch.cfg to another directory temporarily and see if it still does it even with a fresh, autogenerated config. If not, you have some option somewhere that’s causing it and you can try bisecting your config to find it.

Otherwise, something else is wrong, possibly related to this thread:


#3

I have a pretty similar problem but in my case, it doesn’t take THAT long, I’m talking about 5-6 seconds maybe 10 at worst and I launch my games through Attract Mode (a Frontend), I have the same behavior, it may or not may that long, sometimes it launches instantly, other times it takes 5 or more seconds, the weirdest thing is that this also happens with the standalone mGBA emulator and maybe some other games but I don’t notice the load time because those games do need longer load times, I’ve even reported it to Windows Feedback but no upvotes or response at all but with that mGBA same behavior I think this is related to Windows.


#4

Using a fresh config didn’t seem to help, and neither did cutting my current config in half. I downloaded mGBA and noticed that, indeed, it does take quite a while to start up, although not to load games like Retroarch does. Higan also has a similar behavior. I’m starting to think this is an issue with Windows in general, or maybe some kind of background program conflicting and slowing them down.


#5

Yep, just tried FB-Alpha standalone emulator and it has the same behavior, it has to be related to Windows Fullscreen Optimizations or like Focus Assist messes with the Alt Tab on games… oh Windows…


#6

Do they start normally after you start up or restart your PC? It’s another thing I’ve noticed, where these programs will start quickly like they’re supposed to once my PC is restarted, but will eventually slow down.


#7

I may be having a similiar issue. My log shows no problems, but RA appears to freeze on most cores. Maybe I need to give it a full two minutes like you’re doing before it loads. I’m going to do some more testing and let it run for at least a few minutes.

Also, I’m running RA on a mini-PC hooked into my receiver, and then my TV. Sometimes the receiver thinks there is no signal and I think it may be resolution changes happening in RA. How can I ensure that every core is outputting 1080p?


#8

So, I’ve been running a nightly build and thought that might be the issue. I went to the latest stable, and with a default config file, things loaded just fine.

But even with a default clean config and the latest stable, if I turn on fullscreen, then RA cores almost all lock up.

I went back to my bleeding edge and my customized config, turned off fullscreen and it was fine.

Now I just need to play around with different video settings and see if I can get it to work in fullscreen, but this may be a bug I need to report.


#9

It’s random, I’ve tried disabling my startup programs and even did a clean install of Windows 10 but I still have this issue.


#10

I haven’t tried with nightly builds but I did try with a clean Retroarch folder and config and I got the same issue, however and as I said, it doesn’t happen only in Retroarch so this must be a Windows issue, the dumbest part is that it happens randomly and in my case it just takes like 5 or 10 seconds at most, not THAT much like with Harpuia, I’d be really frustrated if I was him/her, lol, but it is still annoying when it shouldn’t take that long, I love when I launch a game through my frontend and it boots instantly… I hope this gets fixed.


#11

So… A little and weird update: Today, my pc took like 10 times the normal time to boot so I checked the event viewer to see if there was something wrong and while checking the logs, there were several Windows Error Reporting errors with Retroarch (it has nothing to do with the boot time, I fixed that lol) right now I have like 20 of them, they started popping up since yesterday and all of them have something to do with two things, Epx.dll and the mame_libretro.dll, have a look here:

It is kinda weird that this started appearing when I’ve been having this problems before they appeared, lol, but I hope it helps or something.

Edit: I forgot to say that I tried moving Epx.dll out of the Retroarch folder to another location and these error keep appearing.

Edit 2: lol, they keep appearing and I’m not even using Retroarch wth


#12

Huh, it happens with standalone Dolphin as well. Some of my games on Steam are launching slowly as well, although it’s a lot harder to say if that’s just the game or the same issue affecting Retroarch.


#13

Yeah, at this point I’m just convinced it is about Windows, oh well, let’s wait for the next major update so they make it even longer, lol.


#14

I use Windows 10, LTSB version which only receives important security updates, like Windows XP or 7, I have none of the above issues.


#15

Hm… Tried uninstalling and reinstalling graphics drivers, reinstalling DirectX, doing a clean boot, and no results. I’m pretty much stumped. Retroarch has too many features for me to go back to most standalone emulators, so I guess I can grit my teeth and bear it and just hope something happens to fix it. Honestly, It wouldn’t be so bad if it only happened when I started retroarch, but since it sort of closes and starts back up when you load a game (that’s probably not actually what happens, but you know) and I have to wait each time, that’s the real kicker. Oh well


#16

Well, I finally figured it out; it was my Corsair k55 keyboard the whole time. I’m not sure exactly what it is, but there’s some kind of driver issue that happens with programs that can use Directinput. If Retroarch is launching slowly, I can unplug my keyboard and it’ll be as snappy as it should be.

Now, I just need to figure out if there’s a way to make it permanent now that I know what the problem is, since it’ll eventually go back to running slowly when I plug the keyboard back in.


#17

It seems 1.7.4 version solved whatever was causing that.


#18

I upgraded to 1.7.4 and it still happens when my keyboard’s plugged in, although it seems to take longer for it to actually start happening which is better


#19

Just created an account to thank you for finding it out, I was really feeling frustrated by this issue (I have K55 RGB myself). Thanks a bunch!


#20

It fixed itself, I don’t remember when exactly, but it happened again today and I remembered that I changed the Nvidia control panel 3d settings for CEMU (yeah, CEMU, not Retroarch) and I think that’s when it started happening again, so today I clean installed my drivers from Geforce Experience and restarted and it’s fixed again, BUT I yet have to keep testing it through more reboots, maybe it will appear again, who knows.

BTW, Sorry if we are reviving this thread too much :c