RetroArch recognizing both user 1 and 2 gamepad as same input (PLEASE HELP)

So I have been pulling my hair out while trying to get RetroArch to properly function on Mac OSX (or even bootcamp for that matter). If anyone could help me out I would greatly appreciate it. I’ve been trying to set this up for over a month now, and nothing seems to be working. At this point I’m either going to revert to using OpenEmu—which will entail imputing each rom graphic by hand—or using Kodi’s setup. Honestly I do not want either of those options. I love how RetroArch feels and functions as an all-in-one retro gaming console. PLEASE PLEASE HELP lol.


RetroArch is fully functioning, except for one issue; every time I plug in my two USB gamepads into USB port 1 and 2, RetroArch recognizes them as the same gamepad, in the same USB port. Subsequently, when I attempt to play a 2-player game, for example, both gamepads control both player 1 and 2. You can see how this make for an interesting gameplay.

When I plugin controller#1, RetroArch displays that I am plugging in “iBuffalo Classic USB Gamepad Configured in Port #0”, and when I plugin controller#2 it displays the same dialogue, “iBuffalo Classic USB Gamepad Configured in Port #0”. Input settings both User 1 and 2 input settings come up as “Device: RetroPad”, "User # Device Index: USB,2-Axis 8-button gamepad (#1). I try to change the index, but there are only these 5 options: USB,2-axis 8-button gamepad (#1); N/A (Port#1); N/A (Port#2; N/A (Port#3; and None.

Troubleshoot Attempts

I have tried disabling auto config, but that doesn’t help either. The only difference is that the actual controller “iBuffallo” doesn’t come up and RetroArch reverts back to the main Config file and device label, that is “USB,2-Axis 8-button gamepad.”

Now I’ve troubleshooted many different things to attempt to fix this and I haven’t had any luck.

[ol] [li]I first thought that I had an issue with my USB ports and Controllers, but that isn’t the case, for I’ve tested out both gamepads in OpenEmu and it binds both controllers without any issue.[/li][li]I then decided to rig it by installing Joystick Mapper and binding gamepad#1 to mimic my keyboard so that in RetroArch I could use the Keyboard for User-1, and the Gamepad for User-2. In theory you wold think this would work, but I ended up with controller one controlling both players, and controller 2 only controlling player 2 (half fixed).[/li][li] I have also tried different versions of RetroArch: both Stable and Nightlies—no fix.[/li][li]I tried to change my device drivers in RetroArch but I only have the “hid” option.[/li][li]I tried to change the master config file, but there doesn’t seem to be any change. Plus once I fire up a game the entire config file seems to be overwritten back to default, or by the actual core.[/li][li]Hell, I even decided to install RetroArch to my Bootcamp Windows 10, but that was even worse. The controllers worked perfectly (I think because the option to use the xinput driver) but hardly any cores actually functioned without either crashing or doing nothing (especially any Saga cores).[/li][/ol]

SETUP Macbook Air mid2011 OSX 10.11.06 2 USB 2.0 ports

Retroarch Build Date: Aug 21, 2016 (Current Nightly) Input Driver: cocoa (only option) Joypad Driver: hid (only option)

2 iBuffalo Classic USB Gamepads (USB,2-Axis 8-button gamepad)


I have the same issue with 2 wired XBOX-Controllers. In the “Xbox 360 Controllers”-Panel I see 2 Controllers (1 XBox-360 and 1 XBox-One), but in RetroArch I have just one Controller and both are detected as the same.

Had the same issue using a SNES8BITDO with NIMBUS steel series, nobody helped me. The only work around was using two nimbus controllers.

1 Like

So, I tried a new software: OpenEmu

With this software both X360-Controllers work like they should. You can see 2 Controllers in the menu and they are configured as Player 1 and 2. So, its not a problem with the drivers, but a problem of RetroArch or its configuration. I hope, that anyone can help us…

Just wanted post here saying that is issue is still present. When plugging in 2 Logitech F310 gamepads retroarch sees them as 1 controller. I think this is specific to the Apple version of RetroArch as the linux version recognizes them separately just fine. Will update after testing on a Windows machine.

Hi magevideogames, I had the same issue, check the following settings:

Sets which libretro device is used for a user.

Devices are indentified with a number.

This is normally saved by the menu.

Device IDs are found in libretro.h.

input_libretro_device_p1 =

input_libretro_device_p2 =

If desired, it is possible to override which joypads are being used for user 1 through 8.

First joypad available is 0.

input_player1_joypad_index = 0

input_player2_joypad_index = 1

Opps. Just realized I never posted after testing this. Tried manually editing the file as above but it still treats both controllers like 1. Not sure what else to try now.

Hello, I have the same problem with 3 iBuffalo usb pads. When I’m in User x device index, it only offer to choose USB xxx gamepad (#1) Did you guys figured out ? I don’t understand your solution jtadeia…

1 Like

I had the same trouble. I just did bind all for user 1 and user 2 via my first gamepad. So once mapping was all set I just clicked the option for “all users control menu” under the input section of Retroarch. Worked perfectly. I don’t know if that would work across the board. I’m using 1.5.0 stable for OSX in case you need that info.

Hi jstu902 I think I solved the problem with retroarch regonzing player and player as one controller. To disable this I found if you into input section in retroarch, then go to User 2 binds and go where it says user 2 bind index and choose disabled. I found if do this for user 3, 4, 5 bind after setting up user 1 bind it fixes this problem. Hope this helps everyone.

My input is my keyboard for n64 but I can’t get the analog stick to work, or the C buttons, the rest I can map on a keyboard. Same goes for playing ps1 games on retroarch, analog won’t work, but the shape buttons the Ls & Rs, start & select work.