RetroArch saving over auto config, device indexes don't match


#1

Note: I am using retroarch 1.7.5 on Win10

I have several different controllers I am trying to set up in retroarch: A PS3 controller, an 8bitdo retro controller, a saturn pad connected to a mayflash USB converter, and two arcade fight sticks. I would like to get them all set up with their own autoconfig profiles so that I can easily swap them out when playing certain cores, or double them up (for example, since I don’t have a second saturn controller I’d like to use one of the arcade sticks as P2 for fighting games on the beetle Saturn core, but also want the same stick configured to be P1 or P2 for playing neo geo games on FB Alpha)

Based on what I’ve read this seems to be a valid use case, but I can’t seem to get the autoconfig working correctly before doing the rest. As soon as I plug the PS3 controller in, RetroArch recognizes it as “Xinput controller (User 1)” and not a “PS3 Controller” (I presume this is why the autoconfig file that is already on retroarch for the pad doesn’t load). No big deal, I can manually set it up and it works fine.

The problem is, once I reset the binds to default, unplug the controller and add a new one to set up, RetroArch still recognizes it as “Xinput controller (User 1)”. I can manually set up this controller too, but when I save the auto config file it simply saves over the same one I just did for the previous controller and it fails to work correctly when plugged in.

There are permutations, but this is the core problem i seem to be working off. After a bunch of controller swapping it did recognize the 8bitdo controller correctly in the device index once (and an auto config seemed to load, though I don’t know which), it simply did the same for any other controllers I connected.

The mayflash consistently gets recognized as its own thing, but even her saving an auto config file just saves over a previous one for some reason (so even though retroarch says “I see that’s a mayflash!” The saved auto config output file doesn’t match the name of the device). Interestingly, even when no other controllers are plugged in, retro arch seems to remember a “ghost” of the last controller and still loads it on startup unless I reset the PC. Not sure that means anything but thought I’d mention it.

I don’t really know what else to do at this point and am hoping someone can guide me in the right direction, thanks!


#2

Do you have Steam open or any other program that could be monkeying with your input? If it’s giving you a generic “xinput device” that means something is wrapped around the controller’s inputs.


#3

Steam was probably open and have been open at various times when I’ve been messing with this. I was using retroarch with just the PS3 controller for months and have only recently been trying to add more. If that was what caused it then it seems like something i’m having a hard time getting rid of since I’ve tried this without having steam running before (Or not signed in, anyways) and seem to have gotten the same issue.

The only other things I can thing of that might be causing something wonky are:

  • I am using the SCP Driver toolkit to connect my PS3 controller to the desktop. It’s supposed to be “native xinput support” so I don’t know if that would qualify as a wrapper or not. Without it the PS3 controller doesn’t work on the PC though and i’m not aware of a better way to connect it atm.
  • I have a logitech G13 gameboard I use for some PC games. Retroarch keeps detecting it on start up and I haven’t figured out anyway to make it ignore it when the device is plugged in. One time during my attempts to set up controllers it did seem to think everything was the G13 when saving to autoconfig for some reason. I currently have it unplugged.

I’ll try uninstalling all this stuff and restarting to see if any of it makes a difference when I have the chance and update the thread then.

UPDATE: So I uninstalled SCP, made sure steam wasn’t running, and exited discord (Just in case? I know it interacts with other apps and likes to detect stuff) and seemed to have some success. The SN30 8bitdo and Saturn-Mayflash adapter immediately worked because retroarch was able to recognize them correctly and set the right auto configs. I guess the real issue is not that RA was “saving over auto config” so much as it couldn’t assign the correct auto configs because it couldn’t correctly ID the controllers.

I’m gonna test the PS3 pad last since it may be what caused all this. The arcade sticks both get assigned to the “Xinput controller” series, which is probably correct since they are both xbox sticks. I’m guessing the autoconfigs are set up for gamepads though since it doesn’t respond to joysticks movements or anything without a manual rebind. Not sure how I can get it to distinguish if it’s a problem.


#4

Oh good, I’m glad to hear it’s mostly working. For your sticks, do they have a selector to switch between left-analog vs dpad signals? if so, use dpad (except for MAME; it wants left-analog).