Retroarch Sound Crackling?

Hello there guys, so im playing Links Awakening on the GBA core ( mgba, ive tried other cores as well such as gambatte core) and im having issues with sound. Like if i press Start the sound crackles for like 2 secs then stops. If i press select for my map same thing. I have everything on default (xaudio driver, vulkan). I was curious and downloaded standalone emulator mgba and tried the game and no crackling so the issue is on retroarch, probably sync issue not sure. My rig : i7 7700k ram 16gb GTX1070ti, im using headphones senheiser.

Hmmm I’m not getting crackling with this core ‘’ TGB Dual ‘’ not sure if its a good core or not but no issues so far. Apparently the issue is with Gambatte, wonder what it is lol

The stand-alone emulator might be using a larger audio buffer. You can configure it in RA.

How do I configure it? Can you help me? Thanks!

It should be in the audio settings.

Are you talking about the output rate? Mine is 48000 which is default i think.

Nope. “Audio Latency”. It’s in milliseconds. The higher you set it to, the less crackling/dropouts you get, but the higher the audio lag becomes. I think the default is 64. Try 120 or so.

If you raise this value up to 300 or so but the problem is still there, then this setting is not at fault. You can set it back to default in that case. It’s probably a core bug if this setting doesn’t help.

I have written extensively about this my experience with a similar, if not identical issue here:

Audio Crackling and Stuttering, Except when Recording

If the nature of your problem is similar to mine, you could try the following:

Install OBS Studio, which is a free, open-source screen recording program. I swear this is not an advertisement. Set a hotkey to start and stop recording. Make sure OBS Studio is set to use Direct3D 11 as its Renderer under “Advanced” settings. Under “Output” settings, set your recording directory to a location with a fair amount of free space, with at least 20 GB being optimal. I also recommend setting OBS Studio to always minimize to the system tray and to minimize to the system tray when started under “General” settings. Finally, minimize OBS Studio, and start recording using the hotkey. The system tray icon for OBS Studio should have a red dot on it when recording. Finally, open up Retroarch and see if the sound crackling is gone. Given your specifications, your system should have no problem recording and gaming at the same time.

I have now found a solution to this problem, at least for users of NVIDIA Graphics Cards experiencing the same version of this issue as me. Go into “NVIDIA Control Panel” by right-clicking on the Windows desktop and selecting it, navigate to “Manage 3D settings,” and change “Power management mode” to “Prefer maximum performance.” If that was already selected, then make sure the Windows Power Plan is set to “High performance.”

Finally, make sure that neither the CPU clock speed nor the GPU clock speed are going much more than 100 Mhz below their maximum non-overclocked levels. If they are, make sure that the CPU, GPU, and Windows power settings prioritize performance over power-savings. For users of AMD cards or Intel Integrated Graphics, there is probably a similar GPU power setting that can be changed to remedy this issue.

For more details about how I solved this problem, see my second post here:

Audio Crackling and Stuttering, Except when Recording

In “NVIDIA Control Panel,” it is also possible to change the “Power management mode” to “Prefer maximum performance” on a per-application basis. That way, the global setting can still be “Optimal power” while RetroArch’s application-specific setting is set to “Prefer maximum performance.”

1 Like