Retroarch ui not working on Windows 10 connected to 4k tv


#1

win 10 with nvidia 1050ti connected by hdmi to LG 4k tv. when launching retroarch ui, it does some flashing and only displays a small horizontal top portion of the ui. i can’t use it. wondering if there is a setting in the retroarch.cfg i can tweak. i did copy this retroarch 1.7.3 folder to this pc from my pc that is connected to a LG 1440p monitor in case that matters. thank you.


#2

You can try moving your retroarch.cfg somewhere else temporarily to see if that helps, but there’s a known issue with Nvidia+Win10+4K with some black flickery lines, if that’s what’s going on. The workaround in that case is to set a video_fullscreen_x/y of 1920x1080 (or whatever as long as it’s not 4K…)


#3

thank you. i tried that and it did allow the RA ui to look normal and become usable, except that the ui is not nearly fullscreen now. i also set it to 3840x2160 but it still comes up much smaller than than fullscreen? the games also only come up in the top left 1/4 of the screen now


#4

so i fixed the gui problem by leaving video_fullscreen_x/y to 0 and disabling video_hard_sync. video_hard_sync was causing RA ui to be unusable only showing top 1/4th of screen. setting video_fullscreen_x/y to 1920 was no good because then the RA ui would come up only 1/4 size in the top left of the screen. i’m not sure what i’m losing by having video_hard_sync disabled but at least the RA ui works now, even though it flickers.


#5

i think vsync was also giving me troubles. disabling vsync seem to have fixed Saturn games being chopped off top of game and also RA ui flickers less


#6

This topic is also being discussed here:

…and here: