Retroarch with Manjaro KDE stuttering


#1

Hi, I hope anyone can help me with this issue. It’s giving me headaches for a week, and I find no solution. I am running a Manjaro KDE system, updated to latest, and if I run Retroarch in another terminal (using CTRL-ALT-F2 for example) it goes smooth and clean, perfect. All synced, no stuttering. KMS does it’s job. However, if I launch RA from KDE, in the desktop, this happens:

  • Noticeable stuttering.
  • I can’t return to RA XMB (that is, if I press F1 nothing happens, so I have to close RA using ALT-F4).

I think I have tried every RA configuration option: changing video and audio drivers, vsync and so on. Does not matter if using shaders or not, using vulkan gives the same result…

I want to run RA from desktop as I use a launcher (Gamebase). And I can’t run RA from desktop on another TTY.

Any ideas?


#2

you could try compiling with --disable-qt to see if the Qt desktop UI is conflicting with something in your KDE environment.


#3

Thank you! In order to build the same options as the regular version in the Manjaro repositories but without the qt, should I just ./configure --disable-qt or I have to add all the options here?


#4

It should autodetect everything else based on the presence (or not) of the various dependencies.


#5

Ok, I will build it and post the results tomorrow. Thank you for your help @hunterk


#6

Just did the build with --disable-qt… no luck, same behaviour, stuttering.

I found something interesting: the CPU use is higher when I am on the desktop, and the cpu gets hotter so the fans sound more. But, if I switch to console (TTY2) for example, and run retroarch there, the CPU usage is minimal, and no fan noise.


#7

Hmm, okay. I guess the next thing to try would be changing your menu driver to “rgui” from “xmb”


#8

Same with RGUI. What I fixed is the hotkeys changing from x to udev driver. Not really interested in fixing that really now, I just want to get rid of the stuttering, but oh well, nice to have them working in desktop. I am trying also all the audio drivers and options, no luck so far.


#9

I found the problem! It was the compositor + x input driver. If anyone experiences this problem using Plasma KDE desktop (I am on Manjaro distro), just create a script file to launch RA (just save this code to retroarch.sh file and the launch it using sh retroarch.sh, or editing the desktop launcher accordingly):

#!/bin/bash

qdbus org.kde.KWin /Compositor suspend

retroarch

qdbus org.kde.KWin /Compositor resume

And change input driver to udev. I also changed audio to alsa to avoid popping.


#10

KDE / Plasma is really not the best DE for gaming. I experienced some serious slowdowns too (especially on Wayland it seems). Now everytime I wanna launch Retroarch, I quit the desktop and goes to KMS which works wonderfully.


#11

I had high hopes with Wayland, just to find out is not up to the task. I had the same problem (worse in fact) in another 4K computer, in which I usually reboot to windows when I want to use RA. Anyway, disabling the composition solves the problem if I do not want to reboot to a windows environment.


#12

Well, the thing is, you cannot disable composition under Wayland, it is part of the protocole… You can only do it on X11.


#13

I thought wayland was the default in manjaro plasma (in fact, if I switch tty it does instantly without blink). The qdbus org.kde.KWin /Compositor suspend works (all window animations and all are suppressed).


#14

I would be really surprised that Wayland is the default on Manjaro Plasma , since the Plasma / Kwin / KDE devs still don’t recommand Wayland as default or for everyday use.


#15

Oh I see. I will check later, but probably I am not using Wayland then, as the installs are just the default ones. Will Wayland perform better with RA?