RetroArch won't recognize any shaders


#1

So I’m baffled more people haven’t had this problem, or maybe I’m simply a dunce and can’t figure out how shaders actually work.

So this is the problem I’m having, RetroArch won’t recognize any shader files. Meaning glsl, cg, glslp, etc. When a game is running, I will try to Load Preset but every folder shows as empty. They are not empty though. I can see they’re there in Windows Explorer

I should mention I did a fresh install of 1.7.5 and I’m on Windows 8.1

I figure it was a firewall issue or Windows defender but I have both turned off. I also have full permission to read write everything in the retroarch folder. So I have no clue

I should mention that I also can’t use the online updater (gives me “task failed”), but I figure since I already downloaded the core I wanted manually (PCSX) I figured that was it for that… Really testing the game it works fine, it’s just shaders that are completely MIA

Not sure if I should make a topic asking for help getting the online updater working first, and then ask about the shaders, or if they’re independant from each other.

Thanks for the help in advance


#2

If the online updater is borked, the first line of defense is usually to move your retroarch.cfg somewhere else and let it generate a new one for you from scratch. If the online updater starts working after that, you probably had an old/bad URL in there somewhere.

For the shaders, what video driver are you using? If the default GL, glslp and cgp presets should both be visible :confused: If you’re using the ‘load shader preset’ option, only presets will show (the ones ending in ‘p’). If you’re adding passes manually, no presets will show.


#3

Thanks. I generated a new cfg file but still gives me Task Failed. Oh well

Thanks for the shader help though it was in fact me being dumb. Changed my video driver to OpenGl and now they work. D3D doesn’t recognize any though. Still, good enough

Thanks you again


#4

Hi, I think D3D will work with the slang shaders if you wanted to try :wink: