REWASD in Retroarch?

Hey guys… anyone using REWASD with Retroarch? I’m trying to get the rapid/turbo fire working in MAME (current) so I can avoid some button mashing in a few games, but I find that the buttons I assign rapid fire to in REWASD aren’t responding in RA. For anyone who has this working… is there a trick to it? Will it just refuse to cooperate with RA, or is there a certain way I need to set this up? Thanks for any help you can offer. :slightly_smiling_face:

More info… I tried this on other cores and got the same effect, but it looks like the rapid fire is producing a slow and erratic fire instead of quick and steady… almost none at all. I posted about this at REWASD and they were quick to say it must not be compatible with RA, but it also sounds like they have never used Retroarch and don’t know anything about it.

Alternately, if no one knows anything about REWASD, but can recommend another software solution to end the button mashing (turbo) for Xbox controllers I would appreciate the recommendation. Thanks, everyone.

Ok… I had to spend a lot of time on this but I have it fixed. For anyone with problems with REWASD rapid fire, try setting the turbo speed to 10ms. This is much lower then the REWASD people suggest using, but it was the only way I could get it working across all the cores and games I tried. For anyone having problems with the built-in turbo in RA, this may be a solution for you… but make sure you try this setting, as the setup can be frustrating. I hope this info might help someone in the future.