RG350, arcade and "unsupported video mode"

Hey there!

First of all thanks zillions to whoever contributes, closely or remotely to LibRetro! Bringing emulation closer to the masses is a very noble task, and you’re doing great!!

I am experimenting with RetroArch on the Ambernic RG350. Followed guides such as https://retrogamecorps.com/2020/12/24/guide-retroarch-on-rg350-and-rg280-devices/ and others.

All is nice and rosy: NES, Megadrive, PCEngine run fine. SNES also (if i disable rewind… ;)). Even NeoGeo works like a charm

BUT… (there is one) when trying to load anything with the FBA CPS1, CPS2, or Mame2003, i got this annoying black screen saying “Unsupported video mode”

sometimes for a 384x224, sometimes others… Isn’t there supposed to be some scaling of some sort? What am I doing it wrong? I tried modifying all parameters in “scaling” to no avil… i am now running a bit in circles. Is there something to configure with the cores that i missed? Or is there no down-scaling (the RG350 is a 320x240 screen i think)?

Thanks for any help telling me where to look and how to make that work!


(same happens with Playstation games, with 2 messages of “unsupported video mode”. probably one for the intro and one for the game itself…)

Just curious, how would that even work ? Discarding pixel rows & columns at random ? Is there even a point in playing those games if everything will look like crap because of missing pixel lines ?

I remember trying to play snes on nds a few years ago, it was an awful experience.

1 Like

I do it routinely with FBA or Mame on the RG350 and it’s amazingly playable!

I guess averaging pixels down, like they are averaged up when upscaling… bilinear, bicubic, etc…?

as the screen is small, you don’t really see the difference anyways, but that’s my humble opinion (also the RG350M and RG351 have a 640x480 screen… but it’s draining more battery, so some commenters mention prefering the original lores one!)

man. i wish i remembered how i set up my 350. are you using fbneo standalone or the retroarch core? Because I use the stand alone and it works fine. I also use a stand alone for ps1. And I also use simple menu

1 Like

He says FBA so i’m assuming he is not using FBNeo.

Are you talking about our sdl port ? It’s quite incomplete though, you can’t even remap inputs.

1 Like

When i use FBA (not neo) standalone it works fine. It’s with the FBA cores that i have this problem. Same for PS1.

I didnt even know there was a FBNeo for the RG350… I’ll look into it… but using standalones kind of beats the purpose for me of switching to retroarch in the first place :confused:

The sdl port can be built on any platform with sdl support. That would be the only official port aside from the libretro one. Yet again, it’s lacking some basic features like an ui for remapping.

1 Like

I wouldn’t know where to start to cross-compile for the RG350… and cannot find a pre-built OPK…

Yeah it might actually be FBA. I honestly cant remember. I set mine all up back in 2020. And I understand what you’re saying about retroarch because to this day I still cant get it to load a rom from within simple menu and Ive tried all kinds of different ways using the command lines. Its a bitch, but for fba and ps1, I use stand alones. The closest Ive come is whatever my CLI says for pce CD, it will boot up retroarch via simple menu but it wont load the rom I choose. It just takes me to the “load core, load content” screen of retroarch. Good luck, bro.

1 Like

I have made progress installing the very hacky “opendingux beta” following instructions from:

it tremendously improves performances, and by using a special “opendingux beta” version of retroarch (available from the download page) i have 1/ significant performance increase 2/ arcade now works!!!

only thing is i dont find no equivalent to the “frontend_start” script, that i used to load automatically the last played game (and its save state) which made it so flawless as an experience…

still working on it, will report back :wink:

thanks for your support!