RPI Overlay on touch screen only accepts single "mouse-like" input

Long Post so get ready.

I purchased the seeed studio reTerminal:

I have been experimenting with the device for about 3 weeks now and I have come across many many issues with using this device for RetroArch.

Most online tutorials regarding Raspberry Pi recommend Lakka or RetroPie. However this only barely works.

Installing Lakka only partially works. The device turns on, but the display is blank. I can connect an external HDMI monitor and the Lakka menu does work, however I cannot configure anything. I use a plug-in keyboard, and it does not work.

Using the Raspberry Pi Imager, there is an option to enable SSH. This fails.

Attempting to SSH fails using the “put a file named SSH” in the boot directory.

So i gave up.

Next up is RetroPie.

Install, device turns on, blank screen. :slight_smile:

Blank screen is resolvable by reading the “Getting started” guide: “Install reTerminal drivers”


I can do this with the SSH setup with the Raspberry Pi Imager.

Problem #1: The boot screen is sideways. Solution:

Problem#2: EmulationStation is sideways. STILL Solution:

Problem#3: RetroArch main menu is sideways. STILL But each core can be manually forced to rotate the image. I found No solutions.

Problem #4: Using an overlay shows a controller, but none of the inputs work when using a touch screen.

So I gave up. AGAIN

Now, I start over using a base image for Raspberry Pi THE SCREEN IS BLANK. So again I install the drivers with SSH.

Now, I find a tutorial on how to Install on Raspberry Pi (Stand-alone)


to my amazement, it actually works! I was able to add games and play them with a keyboard.

Now, for the reason for this post:

I turn on a controller overlay, and touch the display. I see my mouse cursor move to where my finger is. The Button is pressed!

I try playing a game.

It does work, the touch screen works, BUT I can only press ONE BUTTON at a time. Have you ever tried playing Super Mario with ONE button being pressed at any given time?

To clarify: Press “O”, then Press “>”. “O” is then un-pressed and “>” is pressed, even tough my finger is still on the “O”

I have tried the only “hacky” solution that I could find:

And that solution required running a script.

That solution fails.

I see the script moving the mouse in a strobe-like fashion and now apparently the touch screen calibration is off, as when I press anywhere on the bottom left quarter of my screen, It now registers the input as Down and Left at the same time.

Exit RetroArch, touch works normally (as a mouse).

What I am trying to do:

Use an onscreen controller with multi-touch input.