Running RetroArch in fullscreen (not windowed) at 1080p on 4k display


#1

I’m in the process of upgrading my emu box from a NUC5i3 to a NUC8i3. I have it connected to a 4k TV via an AV Receiver. However, even the new NUC runs poorly at 4k when using shaders. What I am trying to do is have Retroarch run at true Fullscreen at 1080p instead. However, the problem is when I do this Retroarch opens like its full screen (no Window chrome around it) but only takes up 1/4 of the screen. I can still see my desktop behind it. It’s like its running at fullscreen 1080p but the display output is staying at 4k.

I didn’t have this issue with the NUC5, I used identical RetroArch settings with it and it behaved as I wanted it to. The NUC5 was running RetroArch 1.5.0 (I think, maybe 1.6.0) and the new one is running 1.7.6. I am using Windows 10 1803 and have the most recent Intel graphics drivers from the Intel website.


#2

Try right-clicking on the retroarch.exe and, in the compatibility tab, try messing with the ‘override high dpi scaling behavior’ and ‘disable fullscreen optimizations’ options.

Also, make sure you have video_fullscreen_x/y options set to 1920 and 1080, respectively, in your retroarch.cfg.


#3

video_fullscreen_x/y are definitely set to 1920/1080. I’ll look at the .exe settings when I get back.


#4

This may be a stupid question, but is your AV receiver 4K capable?


#5

Yes, Windows is outputting 4k just fine - even when I want RetroArch to only be 1080p.


#6

Overriding the DPI scaling behavior and disabling optimizations seems to have done the trick. Now, on to the next issue: No audio using HDMI