Sega Saturn Kronos: Black Screen no lighting in Panzer Dragoon Saga

Hi, I’m back again with a new computer, new graphics card (Nvidia Gforce RTX 4090) and having problems emulating Panzer Dragoon Saga again using the RetroArch Sega Saturn Kronos core.

This time the title screen and intro movie load as normal but when I’m able to walk around in the first area of the game I have a partially lit area that is almost all black. I can see the water reflection coming from the ground, but the walls of the level are not lit up or visible. The walls should be brown with a dragon crest hanging on the wall. Here is what it looks like:

My specs:

|Processor|AMD Ryzen 9 7950X 16-Core Processor 4.50 GHz| |Installed RAM|64.0 GB (63.1 GB usable)| |System type|64-bit operating system, x64-based processor| Graphics card: Nvidia Gforce RTX 4090

Just wondering if anyone knows what’s causing the problem or if it can be fixed in a Kronos core update. Thanks.

This regression has been known for quite some time :

There seems to be a workaround involving enabling the HLE bios (core options).

FCare, the author of Kronos, is on a hyatus (lots of things happening in life). He’ll eventually go back to his project.

Thanks for the reply. Enabling HLE bios in the Kronos options did not work for me though. Is it possible to revert to a previous update where the game was running correctly? The update where the invisible text was fixed I believe was the last confirmed working build:

[Panzer Dragoon Saga] missing texts in in-game documents · Issue #1161 · FCare/Kronos (

Also, on a side note: I tested some other Saturn games on the current RetroArch Kronos build. And with some games the sound/framerate is speed up way too fast. For instance, with Nights into Dreams.

I won’t revert the source code every time a regression on 1 game is found, otherwise there would never be an end to this.

What’s your platform ? I could probably build a custom core at an earlier version for you, except if you know how to do it by yourself.

My platform is Windows 11 64 bit. I have no knowledge on how to do it. But if you could make the build right after the missing text was fixed that would be great. Would I just drop the files in the RetroArch core folder or some other folder?

Use Beetle Saturn or Yabuse as works way better in my Opinion

I tested Beetle Saturn and Yabause in RetroArch and they don’t work. Standalone Yabause works well outside of RetroArch though, apart from some controller issues.

What Controller Issues?

Might need to use Standalone for Panzar Dragoon Saga

Tried Different Video Drivers?

I don’t know about yabause but i’m pretty sure beetle-saturn can run PDS just fine. This is probably a setup issue on your side, make sure you are following the core’s documentation as you should for any libretro core.

Using beetle-saturn which is the best in terms of compatibility/accuracy would be my recommendation too.


I am not really familiar with this game so I can’t comment on how it looks, but it does run on Beetle Saturn.

1 Like

Yes, I tried everything. I’m talking about controller issues with standalone Yabause.

I’m only ever able to get the L and R buttons mapped with the pad option only. The 3D control pad option would not map the L and R buttons. You have to set the controller for Pad. And you have to map the movement to the d-pad because for some reason Yabause has issues with controller input settings and the movement can’t be mapped to the analog stick for some reason. But the pad option will ensure you at least have all of your buttons mapped, just without analog movement. And the L and R have to be mapped to the top L1 and R1 buttons, doesn’t map to any back triggers of a 360 controller for some reason… But ironically for some odd reason the 3D controller option works with Nights into Dreams just fine though…except when you’re walking around with the kids.

I just really like Kronos though, for the upscaling. Just hope it can be fixed and updated at some point. Were you able to re-build that custom version of the older Kronos core?

I’m using linux and i don’t have a windows building environment available right now. I’ll try to install one next week-end if i’m not too busy.

Okay, thanks appreciate it.

You Changed Bios?

Tried Clean Install of Retroarch?

Concerning the controller issues. I wasn’t talking about any of the Sega Saturn cores in RetroArch. I was talking about standalone Yabause version 0.9.15. Which is the main Saturn Emulator I use outside of RetroArch. The controller works fine for the most part using the ‘pad’ input option, but you just can’t map to the analog, only D-pad. But oddly, Nights into Dreams actually works with the 3D Pad control option for some reason, but not with Panzer Dragoon Saga.

Just wondering if you can still send me that old version of the Kronos.dll Core. Would really appreciate it if you have the time.

Kronos 2.6.0 was finally released and should be available soon from retroarch’s online updater.

1 Like

Thanks, appreciate it!