Shader on Windows RetroArch Issue?

shader

#1

I googled and tested a lot before asking this question here. I actually feel a bit silly because this was asking in so many different ways. But here we go.

I’m in RetroArch 1.7.6, cores etc all updated. Latest build of Win10 pro 64bit with NVidia 1080gpu and AMD threadripper2 CPU

I’m simply trying to get a shader with scanlines, GRT curvature (geom) and bloom working on Genesis games with PicoDrive.

When I use GL as the driver, GL NTSC shaders give me scanlines and bloom. But no geo.

D3D11 driver seems faster, but seems like only Slang shaders will load?

Here are my 4 actual problems: When loading GL CRT-Royal drivers, the blue in games turns pink. When loading Slang drivers, there is no CRT-Royal. So I’m not sure which one would be best? None seem to work correctly. No matter what, I’m never seeing curvature. I wanted to start over, so deleted the games preset. But now it doesn’t ask me to simply load a shader. It asks me what I want for shader 0,1,2,3… If I limit the number of shaders, loading a shader that should have more passes does nothing.

I know that’s a lot. But any help would greatly be appreciated! Thanks all!

This was all so much easier in Lakka on rpi. :sunglasses:


#2

Yes, d3d11 can only load slang shaders. GL can load Cg and GLSL shaders. There is a crt-royale port for both slang and GLSL (it was originally written for Cg) but the curvature parameter doesn’t work on the GLSL or slang versions (it’s very complex code and I could never get it to work right).

However, there are a number of shaders that should do what you’re wanting. Crt-interlaced-halation, crt-easymode-halation, crt-lottes, crt-guest-dr-venom, and probably more I’m not thinking of at the moment.